[Solved] Unable to mount External HDD NTFS

Hello guys!

I’m have some issues loading my external HDD (1TB).

I’m making the following steps:

sudo fdisk -l

Device      Start        End    Sectors   Size Type
/dev/sda1      34     262177     262144   128M Microsoft reserved
/dev/sda2  264192 1953523711 1953259520 931,4G Microsoft basic data

sudo mount -t ntfs /dev/sda2 /mnt/piHDD


modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.14.59-v7+/modules.dep.bin'
modprobe: FATAL: Module fuse not found in directory /lib/modules/4.14.59-v7+
ntfs-3g-mount: fuse device is missing, try 'modprobe fuse' as root

I’ve already tried other steps, but the error is always the same. Any idea?


Best Regards,

I found this command


but the result is the same :frowning:

Hi all,

after some digging I found the solution.

Don’t know why but the folder /lib/modules/4.14.59-v7+ is empty. Thats why I was getting that error.

I downloaded the correct files and copy to the folder. Voila! Working.

Downloaded the files from here:


Thanks to everyone.

The error you got while trying to mount the drive is different than mine, but I’m having trouble getting a mounted drive to show. When I saw this post, I didn’t think it was the same issue I was having, but when I looked at the 4.14.52-v7+, I also found it to be empty so maybe this is my solution as well.

I have a couple of questions, though: Can you show me what you read that lead you to check that? It’s not something I really even knew to look at.

Second, did you just download every single thing at the link you gave, put it on a USB drive and move it over with command prompts?


my comments inline: