[Solved] Unable to install Dietpi on eMMC with Odroid XU4Q

I am unable to get Dietpi working on my Odroid XU4Q using an eMMC module. I flash the Dietpi image with Etcher. After inserting the module, then plugging in my XU4, after 20 seconds it powers off. I’ve re-downloaded and re-flashed the image multiple times and the problem still exists. I’m using “DietPi_v6.14_OdroidXU4-ARMv7-Stretch.img” file.

When a flash the same image to a MicroSD card I have no issues at all.

An help would be appreciated. :smiley:

I’m assuming you’ve moved the switch to the eMMC position?

If so, try another non-dietpi image to test the eMMC.

I’ve had two eMMCs fail and the warranty period is very short, maybe four weeks.


Already have and it worked fine.

Noob alert! I totally missed the boot switch on my XU4. It was in the wrong position. It works now. Thanks

No worries, happens to the best :smiley:. Great it works now. Actually I already interpreted your last post as a solved indicator, however now the adjusted topic name is true :slight_smile:.