[SOLVED] Torrent speed on RPi 3 (Deluge, Transmission...)

Hi guys.
I’m trying to use the Pi sa a torrent box, but without any success.
I tried with deluge, transmission and rutorrents (this one NEVER starts to download nothing) all installed with dietpi-software with no luck.

The only thing that I should try it’s reinstall in another SD, but i don’t think than that change anything.

The speed drops down to 0 or download to 5 or 2 kbps ALWAYS with any torrent, any tracker.
From movie trackers to Linux Mint/Ubuntu trackers.
All the torrents has the same issue. With or without VPN. I tried the same SD with DietPi installed on another Pi and I’ve the same results

To check that, I put to download the same torrent in the same connection (behind a VPN) on the DietPi with Deluge and in my laptop with KTorrent.

Fresh install Deluge (please note that other 2 torrents NEVER rech the 100%, and one is from official Linux Mint trackers)

My Laptop with Ktorrent

You can see with the has that’s the same torrent. Please look the speed of each… The were added at the same time.

I can’t figure how solve this or get any clue.



Does you torrent program have write permission for the directories you are downloading (usually incomplete/complete) to?


Hi John.
Yes, they have permission. root:root for complete and incomplete.
It’s funny. The test torrent that I add yesterday for post purposes finish (REALLY SLOW) and the others are still unfinished.

I will cry.

Oh my god…
Finally I can figure the problem and you Jonh, gave me a GREAT clue.
The problem was in the owners, not the permissions.

The directories had root:root as owners. I changed to dietpi:dietpi and now the speeds are correct with Deluge.

Subject changed to SOLVED.

Thanks John.