[Solved] SSH refused. Connection timeout


I changed my router because the old one started to loss connection. After changed, from the hdmi connected monitor, Usbridge showd ip address changed from 192.168.x.239 to 192.168.x.101. The network settings is still DHCP.

However, with the new ip address, I can’t use Putty to ssh login to Usbridge anymore, even the Allo web configuration page also not running. At Putty, it would not allow login and connection timeout message prompted after some time. I checked dietpi-services status, it showed ssh was active and running. I updated Dietpi from v6.14 to the latest v6.16 but the issue still remained.

I further check system settings with “systemctl status ssh”, it says:
[sshd] server listening on port 22
[sshd] server listening on :: port 22

I can’t ping 192.168.x.101 from my local pc also. Could anyone help me?

I also can run:
ssh 192.168.x.101 -p 22

from the hdmi attached monitor but I just can’t remote ssh login to Dietpi from my local pc.

I got ssh to work now. I go to dietpi-config and change Ethernet settings to Static and ip address to Before I changed the ip, the value shown was and gateway was

I think this is wrong, the subnet value x supposed should be 100 not 0. Anyway, it is working now.

Hmm, perhaps some issue/inconsistency with your new routers DHCP server. Did you restart network (ifdowm/ifup, systemctl restart networking, systemctl restart dhclient, or something like that) on the Usbridge after switching and setup new router?

However I mark this topic is solved.