[Solved] RP 3 B+ / Temperature question

Hi all, I have just bought my first Raspberry and I am doing my first steps. - My goal is to run Pi-Hole on it. Having started with Raspbain Stretch Lite, I read about DietPi - and it sounds very good and interesting. So, I re-installed it with DietPi. :smiley:

I am wondering why the displayed CPU temperature is about 4C higher, when I run on DietPi. With Raspbian, my temperatures are around 52-54 C, with DietPi (nothing else installed, Pi-Hole with same configuration) I have 56-58 C.

I have even switched the CPU profile to “conservative” - after that, in the “cpu” coammand, the cores change from 1400MHz to 600MhZ, - but the temperature don’t change…

Any idea, what the reason is?
Thank you very much!

/Edit: Just to make a bit clearer, what I did. I have tried it back and forth with two SD cards und let the system run for 60-90 minutes to watch the temperatures. When running vom Raspbian, temperature goes down. Switching to DietPi, it goes up (and stays up), back to Raspian, the system gets cooler again (and stays there).

May I ask you to create a bug report on github, just we are sure we have the exact device, kernel and version infos? https://github.com/Fourdee/DietPi/issues/new/choose

The only thing I can currently think of is a different default/max clock set, on CPU or also other parts.
Could you add the /boot/config.txt contents to the bug report as well?

Also how did you estimate CPU temperature?

I am currently setting up my RPi2 new, due to microSD failure…again. This shitty SD quality, even from named manufacturers, make me crazy. Other topic…

I will set up current Raspbian Lite first (after bad block check is done on microSD… takes time…) and check the temperatures as well on idle. Then I will run current DietPi-PREP and check as well. But yeah github is the better platform the collect infos, do and test fixes.

Thank you very much for your answer. I have just filed a bug report on GitHub:
I hadn´t done that before, because I didn’t want to call this a “bug” yet. - I rather thought that it was my fault. :wink: Perhaps I did something wrong.

As mentioned in the bug report, I read the temperature from the Pi-Hole web frontend or with this command:

cat /sys/class/thermal/thermal_zone*/temp

Any news regarding your screwed-up sd card? :smiley:
As a newbie to Raspberry, I did not experience this yet, - sounds as if I should prepare myself? :rofl:

PS. My first estimates obviously were not accurate enough. After doing 13 test runs I had a series of measurements and calculated average values. For the bug report I took those more precise values.