[Solved] Problen on updating

On my ordroid c2 i have Dietpi v6.9.0 | Odroid C2 (aarch64).
If i run dietpi-update i have the error visible in the attach image

TKS for the help

Thanks for your report.

The actual error log must begin below to what is presented in your screenshots. You can use up/down page-up/page-down buttons to scroll the log, that does not fit on the screen.

However it is cleanest to run bare:

apt-get update

and copy&paste or show screen of last output lines here, if you have the chance?

root@DietPi:~# apt-get update
Hit http://dev2day.de jessie InRelease
Hit http://fuzon.co.uk all InRelease
Hit http://fuzon.co.uk jessie InRelease
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://ftp.debian.org jessie-backports InRelease
Hit http://dev2day.de jessie/main armhf Packages
Hit http://ftp.debian.org jessie Release.gpg
Hit http://deb.debian.org jessie/updates InRelease
Hit http://ftp.debian.org jessie Release
Get:1 http://ftp.debian.org jessie-updates/main arm64 Packages/DiffIndex [11.8 kB]
Ign http://dev2day.de jessie/main Translation-en_GB
Hit http://ftp.debian.org jessie-updates/contrib arm64 Packages
Ign http://dev2day.de jessie/main Translation-en
Get:2 http://ftp.debian.org jessie-updates/non-free arm64 Packages/DiffIndex [736 B]
Hit http://fuzon.co.uk all/c2 arm64 Packages
Get:3 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages
Get:4 http://ftp.debian.org jessie-updates/non-free armhf Packages/DiffIndex [736 B]
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Hit http://fuzon.co.uk all/main arm64 Packages
Get:5 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [3,688 B]
Hit http://fuzon.co.uk all/testing arm64 Packages
Hit http://fuzon.co.uk all/main armhf Packages
Get:6 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Hit http://fuzon.co.uk all/testing armhf Packages
Get:7 http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex [27.8 kB]
Get:8 http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex [23.9 kB]
Hit http://fuzon.co.uk jessie/backports arm64 Packages
Hit http://fuzon.co.uk jessie/main arm64 Packages
Get:9 http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex [8,530 B]
Hit http://fuzon.co.uk jessie/backports armhf Packages
Hit http://fuzon.co.uk jessie/main armhf Packages
Get:10 http://ftp.debian.org jessie-backports/main armhf Packages/DiffIndex [27.8 kB]
Get:11 http://ftp.debian.org jessie-backports/contrib armhf Packages/DiffIndex [26.7 kB]
Get:12 http://ftp.debian.org jessie-backports/non-free armhf Packages/DiffIndex [8,530 B]
Get:13 http://ftp.debian.org jessie-backports/contrib Translation-en/DiffIndex [7,960 B]
Get:14 http://ftp.debian.org jessie-backports/main Translation-en/DiffIndex [27.8 kB]
Get:15 http://ftp.debian.org jessie-backports/non-free Translation-en/DiffIndex [19.1 kB]
Ign http://fuzon.co.uk all/c2 Translation-en_GB
Ign http://fuzon.co.uk all/c2 Translation-en
Ign http://fuzon.co.uk all/main Translation-en_GB
Ign http://fuzon.co.uk all/main Translation-en
Ign http://fuzon.co.uk all/testing Translation-en_GB
Ign http://fuzon.co.uk all/testing Translation-en
Ign http://fuzon.co.uk jessie/backports Translation-en_GB
Ign http://fuzon.co.uk jessie/backports Translation-en
Ign http://fuzon.co.uk jessie/main Translation-en_GB
Ign http://fuzon.co.uk jessie/main Translation-en
Hit http://ftp.debian.org jessie/main arm64 Packages
Hit http://ftp.debian.org jessie/contrib arm64 Packages
Hit http://ftp.debian.org jessie/non-free arm64 Packages
Hit http://ftp.debian.org jessie/main armhf Packages
Hit http://ftp.debian.org jessie/contrib armhf Packages
Hit http://ftp.debian.org jessie/non-free armhf Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Fetched 208 kB in 7s (29.3 kB/s)
W: Failed to fetch http://deb.debian.org/debian-security/dists/jessie/updates/InRelease Unable to find expected entry ‘main/binary-arm64/Packages’ in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

tks for the help

Which version of DietPi do you use? Some months ago Debian for some reason removed the arm64 arch from their security repo, which is what your APT still requesting. This should have been removed some updates ago.

Ah just found v6.9
I suggest you update to current v6.17 or better later the day v6.18 will be released.

But you can also manually fix:

sed -i '\|deb.*debian-security|d' /etc/apt/sources.list

ks for the help. I have solved