[Solved] problem after update to 6.20

I just updated my dietpi and I see a lot of errors during boot like
"Waiting for Dietpi-Postboot to finish (x/15) - syntax error in expression …

Please see attached screenshot - sorry for blur image - but it scrolls to quick to capture it.
Anyway except that everything seems right now to work (at very first reboot I though that it’s fresh install instead of update, but I enabled services manually and it seems that no data has been lost)

Was the first update you did to v6.20.5 or directly v6.20.6? The previous had this issue in some cases, the latter should work fine.

The error messages you show are due to a minor syntax, although uncritical, to solve this for next reboot, do: sed -i ‘s/G_DIETPI-NOTIFY "Waiting for DietPi-Postboot/G_DIETPI-NOTIFY 2 "Waiting for DietPi-Postboot/’ /DietPi/dietpi/login

You have some autostart option selected, right? Deskop, Kodi or simply autologin to console? In this case the “Waiting” message is expected (although without the syntax error, just the message itself :wink: ), since the autostart/login script waits for DietPi-Postboot service startup.

However it is not optimal, would be better it DietPi-Postboot runs earlier, if some autologin/autostart is chosen, so the login script itself does not need to wait. We are already thinking about how to implement this best: https://github.com/Fourdee/DietPi/issues/2476

You’re right my first update was 6.20.5 with autostart KODI enabled, and as you said after applying “sed” solved this issue :slight_smile: