[SOLVED] PiHole via dietpi-software installation issues


I just wanted to let you know there might be a problem with installing PiHole from dietpi-software!

I tried to get it to work using dietpi-software but it just didn’t work.

I tried multiple clean installs but had no success! It was constantly giving me a 404 Error when i tried to access the admin page.

Then i tried to install it using

curl -sSL https://install.pi-hole.net | bash

This worked perfectly without any issues!

You might want to look into this.


Hi Zombie,

Thanks for the report.

Tested with clean install on C2 with dietpi-software, working as expected.

Which device was this on? And which webserver choice did you use (default is lighttpd)?

It was a Raspberry Pi 1 Model B

I tried for more than 2 Hours with multiple clean installs but it didn’t work.

Then using the official method without dietpi-software, it worked first time without any issues.

Were you using /admin or /pihole?

At first I tried /admin and got a 404 then realised that it’s actually /pihole and everything worked fine

i was using /admin

This is what the installer told me to do!

I had no idea about /pihole

I guess that was the issue!

with the official installation method it works with /admin


I just checked the DietPi Software Thread here in the Forum and there it also states that it should be /pihole.

so my fault. i should have double checked!

I think it’s a fair confusion, as you say the installer also says it will be at /admin and also spits out a password (which is useless because the password by default is dietpi…) potentially there could be a couple of bits of tidying to this install to make it clear how the DP version differs from the main version?

Yep, no worries.

Ok so theres a few adjusments we make, mostly to allow for multiple use of the web server, not dedicated it to PiHole, and, prevent PiHole from overwriting the current lighttpd.conf:

After that, during configuration, we symlink /pihole to /html/admin, as per our online doc:

As our DietPi web server paths are standardized and relative in /var/www (eg: /var/www/myfolder/website_1 = http://ip/myfolder/website_1), the actual location of the PiHole web page (via the official installer) is /var/www/html/admin and therefor the link is http://ip/html/admin

So either of the following will work:

But I will update the code to create a symlink so the following also works, to prevent this occurring again:


Your Admin Webpage login password is 1XR2_UbZ

Also looks like this a new addition. Previously, no password was set for the web interface, hence we do it during install and set to dietpi after PiHole installer is finished.

We’ll inform user of password changed aswell:

Thanks guys,

resolved for v142. Let me know if theres anything else :slight_smile:


Thanx Fourdee! I will test it as soon v142 is released and will let you know about the outcome!


After v142 was released, i did another clean install of DietPi and chose PiHole installation in dieti-software.

Now everything works flawlessly out of the box.

/pihole and /admin both work without any issues.

Great Work as always FourDee.

Now i need to go and annoy the PiHole developers in order to get them to block social media buttons…