[Solved] NativePC ISO -> 24GB SSD?

I am trying to install the NativePC ISO to a 24GB SSD in my PC. I have removed all other HD and SSD so that the install goes to the correct target, a 24GB SSD. The install process (to sda) starts ok, but then breaks off because the image is apparently made from a 32GB source. How can I install to a 24GB target?
Thanks a lot for any help

Did you use the UEFI image or BIOS/CSM?


Okay, I am overstrained with the UEFI Clonezilla-based image, but forwarded your case to the related GitHub issue: https://github.com/Fourdee/DietPi/issues/1171#issuecomment-458554342

I hope there or here someone with more Clonezilla experience can help you.
And the image is quite old and there are plans to renew it with an alternative Clonezilla version (see the linked issue), which should fix some issues users run into.

Until then: Did you try it with the BIOS image? It is way simpler, can be directly flashed/cloned to the target drive without any installer wrapper, ready to run.

Thanks MichaIng
I now tried the BIOS Image and flashed it directly to the SSD. I got it to start to boot, but the boot ended after three lines on the screen. I assume there is some kind of hardware conflict with my Intel Server board.
So I have gone back to my trusted Odroid C2, which works flawlessly with dietpi / Roon Bridge.
Thanks for your help.

I had another go at this.
This time the BIOS image booted and ran through the setup procedure, incl. several reboots. So it doesn’t seem to be a fundamental HW issue.
dietpi running on an Intel S1200V3RPM / XEON Server Platform! Listening to Anouar Brahem through roonBridge now.
Thanks for your help MichaIng

Great it finally works :slight_smile:.