(solved) minidlna stop working after updating to dietpi 7.5.2

Good day.

I have a raspberry pi b+ (v.1) and my server was working good after I updated to bullseye 3 weeks ago.

Today I updated (finally!) to dietpi 7.5.2 and minidlna stopped working.

This is the result when i put

journalctl -u minidlna

This is the result when i put

service minidlna status

What can I do to restore minidlna to a working status?


first, if possible don’t do screen prints pls. Better to connect via SSH and copy content directly. Thx

Back to your issue, this is a side effect of RPi devs changed name/location of some important files. It’s caused by update of apt package libraspberrypi0. Unfortunetaly something out of our control. But we might have a workaround until RPi devs fixed their packages.

cd /usr/lib/arm-linux-gnueabihf
ln -s libmmal_core.so.0 libmmal_core.so
ln -s libmmal_util.so.0 libmmal_util.so
ln -s libmmal_vc_client.so.0 libmmal_vc_client.so
ln -s libbcm_host.so.0 libbcm_host.so
ln -s libvcsm.so.0 libvcsm.so
ln -s libvchiq_arm.so.0 libvchiq_arm.so
ln -s libvcos.so.0 libvcos.so

And restart your service afterwards.

Hello Joulinar and thank you for your fast reply.

I made what you said and minidlna is up again without any problem.

Sorry for posting images… I was on my cellphone and ConnectBot didn’t let me copy the text. It won’t happen again!

Yean in general images are fine but I prefer direct copies from SSH terminal. This makes life easier if someone need to copy an error message and it’s better readable :slight_smile: .

Hey guys, the issue should be solved with a recent FFmpeg update. Can you please verify it works in your case:

apt update
apt upgrade
cd /usr/lib/arm-linux-gnueabihf
rm libmmal_core.so
rm libmmal_util.so
rm libmmal_vc_client.so
rm libbcm_host.so
rm libvcsm.so
rm libvchiq_arm.so
rm libvcos.so
systemctl restart minidlna
systemctl status minidlna