[Solved] loosing the ssh connection adding a static IP

Good morning,
I would set up a static IP and, once I enabled it in the dietpi-config → Ethernet, of course, I lose the SHH connection.
The problem is that using the terminal from a mac I’m not able to connect to the new static IP (.100) any longer. I have to connect a video and a keyboard to the p zero board and reconfigure a dynamic IP.
Am I doing something wrong?
thanks in advance for any suggestion

Just an update:
when I try to connect, the terminal shows me this message:

ssh: connect to host port 22: Host is down

[Process Completed]

Just in case it means something.

Another quick update:
I just notice that in the configuration area of my router the device does not appear, even if I’m easily working on it without any problem, with the screen and the keyboard connected to it.

are you sure your STATIC IP is located in same network segment than your DHCP IP? While setting STATIC IP, there is an option to copy DHCP to STATIC. Did you tried this option?

Hi Joulinar ,
thanks for the message.
I’m not sure what you mean with “the same network segment”. Since the beginning, I had worked on the same router (the zero connected with an ethernet cable the mac via wifi.
Just to show you what I see when I modify the network I attach a screenshot.
After this screenshot, I apply to save all changes and restart networking.
Is this the error?

looks like there is a mismatch. According the screen shot, your current IP is but you are trying to apply an IP address This is a complete different network segment. Therefore I’m not wondering that your system is not reachable after you applied the setting.

Can you switch to DHCP. Once rebooted, go into network configuration again. Switch to STATIC. Now you should see on top a COPY. Copy current address to “Static”. Hit this one and apply the settings.

Thanks a lot for the suggestion.
Using “copy current address to static” works perfectly.
Topic solved :wink: