[SOLVED] Kodi remote apps

Hello guys,

i’m new to dietpi, i’m using it for multi purposes and that’s why dietpi is the option i decided to take.
before that i had raspbian and i installed everything by myself, still i had too much trouble.

when i had raspbian kodi was reacognized by all remote apps on my iphone but when i installed it with dietpi,
not a single app can recognize it, i did fresh installs several times, still nothing.

i did activate zeroconf and all that things in kodi everytime.

i have access to the remote with the 192.168.x.x/8080 on my phone/pc
but with the apps : nothing.

do you guys have the same issue ?

update : doing it manually works, but the automatic detection doesn’t work, zeroconf problem on dietpi ?

Not that we are aware of. Please verify avahi-daemon is installed:

apt-get install avahi-daemon

And functioning correctly

systemctl status avahi-daemon -l

You got it, i first ran

systemctl status avahi-daemon -l

to see if it is running, got an error that it doesn’t even exist ?
so i ran

apt-get install avahi-daemon

to install it, ran

systemctl status avahi-daemon -l

again and magic ! it’s finally getting detected by all my remote apps !
I did several fresh installs of dietpi/kodi on my raspi, i guess the avahi-daemon isn’t installed natively ? :rofl:

Correct :slight_smile:

We’ll get avahi-daemon added to Kodi install by default, for v155 update.

happy to contribute :slight_smile: