[SOLVED] Issue installing build-essential

Unable to install the Build Essential package, getting the following error, whether I run from dietpi-software or using apt-get install build-essential. New install, running v139 on an Odroid-C2. Any ideas?

Mode: Install software
Please wait…

Build-Essentials: common packages for compile
[Info] Please wait…

processing | D i e t P i

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: libc6-dev but it is not going to be installed or
Depends: g++ (>= 4:4.9.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[Failed] The apt cache may be corrupt, apt mirror offline, or you have held broken pacakages. DietPi-Software will now exit.

[Info] Please try:
[Info] - Fixing apt package errors with ‘apt-get install -f’
[Info] - Change apt mirror: ‘dietpi-config’ > ‘Networking: NAS/MISC’ > ‘Apt Mirror’
[Info] - Clear and refresh apt ‘apt-get update’
[Info] - If problems persist, please create a Git ticket so DietPi can investigate the issue:

Nevermind, found this work around already posted on github, fixed the issue I was having. Thanks for the quick fix! :slight_smile: