[Solved] How to run Pi-Hole and FreshRSS at the same time?

I want to run Pi-Hole and FreshRSS at the same time.

As described in the forum [1], the installed Pi-Hole runs at (or /admin).
As described in the forum [2], the installed FreshRSS runs at

[1] https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/23
[2] https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/123

When I install Pi-Hole and afterwards FreshRSS, I get an error from Pi-Hole when calling (that says, that the page doesn’t exist).

Is it possible to run both at same time?


I was unable to replicate on Odroid C2.

Please ensure you change the IP address to match that of your system.


The IP address of the system is displayed in the banner, after logging in.

I have a similar problem with Baikal.
if i enter the url to finish the setup i get the pihole logo and a link to the admin page of pihole.


was able to loan a pi zero from a friend.
clean install with pihole and baikal works there → homemade problem.

so now i have to find out how to tell pihole not to block the side.

Hi guys,

Just to verify, are you installing Pi-hole through dietpi-software?

in my case yes.
only difference i can think of is the version on time of install.
Pi-Hole was installed with v6.6(+/-), baikal with 6.14.
cups somewhere in between.


Edit: pi-hole was updated from 3.3 to 4.0

How did you update Pi-hole?

pihole -up on Pi-hole 3.X indeed breaks other web services, as it moves webroot from /var/www to /var/www/html.
The /etc/lighttpd/lighttpd.conf gets overwritten. I think changing the webroot back should be sufficient to make other web services run again.

To avoid these issues, we recommend that all Pi-hole 3 users update by using: dietpi-software reinstall 93
By doing so, a new (v4) setup variable will be placed to not install/update/config the webserver.
(Or Fourdee was there a reason to dietpi-software uninstall 93 first?)
Afterwards, you can use pihole -up without issues to update to higher versions and use other webservers (via dietpi-software choice) without Pi-hole always forcing a Lighttpd install :smiley:.

used pihole -up

is there an easy way to move webroot?
i am a total noob with linux.

Please try:

sed -i 's|/var/www/html|/var/www|g' /etc/lighttpd/lighttpd.conf
systemctl restart lighttpd

it worked.
Thank you very much

To avoid the same issue with future pihole -up calls, please do the following:


so in the future i have to run dietpi-software reinstall 93 to update pi-hole?

Nope, with the commend you just made, you can from now on use pihole -up without issues.

Thank you, MichaIng, Fourdee and Mordog!
My lighttpd configuration is fixed too now and I can run Pihole and FreshRSS at same time! Great! :smiley: