[Solved] Ethernet issues on Odroid C1 after updating

I’m having multiple issues with getting my Odroid C1 working with dietpi: The initial setup goes fine, and it runs the auto-updater to bring it from v6.0 to v6.16. However, after it reboots the ethernet adapter no longer works and cannot gain an IP address even when trying to configure the adpater in dietpi-config.

I noticed another thread that was sort of similar, but was using a C2 and wifi https://dietpi.com/forum/t/odroid-c2-no-wifi-after-update-to-6-15/2557/1 I added the line as suggested, and while it didn’t fix the networking at boot, I am at least now able to go into dietpi-config manually every time and choose to “save all changes and restart networking”, which fixes the problem. Not really ideal though. Any ideas what the issue might be?

Just wanted to mention that I got this working by replacing my 6.16 files with the 6.17 dev commits here:

The systemctl start networking inside preboot script was the change that finally fixed it for Jessie systems (G_DISTRO=3), if one does not want to apply all those changes :wink:: https://github.com/Fourdee/DietPi/blob/be64a2c84aae9215de1bce6d2684f2d84a1bbd1d/dietpi/preboot#L269-L274

Not sure why but I actually tried just adding that first, but for whatever reason it didn’t fix it for me until I added all the changes?

Strange, during our tests and several user replies it was the other way round.

However, good that it works now for you and this properly helps others as well :slight_smile:.

I have the same problem as described by op here. After initial installation the system updates to 6.16, and after that it cant turn of wifi not connect to Ethernet… I tried changing the files but it still doesn’t work :frowning:( almost 4 hours trying to fix this. Can someone help?

same here, ethernet broken after last update… :frowning:

really no one that can tell me if this wil befixed soon?

There is a current issue, that turning on WiFi + Ethernet the same time and on different subnets, e.g. WiFi on while Ethernet is on, then WiFi connection breaks, at least without setting up a special routing table: https://github.com/Fourdee/DietPi/issues/2103

This could perhaps also break the other way round: Ethernet does not connect. So please try in case to disable the WiFi adapter via



Please also try to update to current beta, since we fixed some interface startups on boot there, which might be related: https://github.com/Fourdee/DietPi/issues/2140
How to apply beta branch: https://github.com/Fourdee/DietPi/blob/beta/BRANCH_SYSTEM.md

thanks but de C1 doen’t have wifi. So disableing it would not help (i’ve tried it)

I can confirm that I have issues on my Asus Tinker Board as well…its hit and miss, mostly miss with Ethernet connection on boot.

Just for kicks I installed another OS [volumio] boots and connects with no problem every time.

Could you please try it with the current beta

And do you have a WiFi adapter attached as well? Could you try to disable it via dietpi-config in case?

€: Ah as mentioned above already. Or did you mean after update to beta?

I would like to try the dev branch for the Odroid C2 except it won’t connect to the network.

Did a fresh install, everything worked up until the last step where I installed the Dietpi system, upon reboot I lost my network connection. No way to ssh into the Odroid C2.

Found the problem…at least for me.

The Ethernet was not broken…it IP address changed !!

I looked on my router and saw a new IP address, I ssh’d into it and behold…it was the Odroid C2.

Next I tried connecting to wifi using a dongle…worked fine.

Rebooted and wifi connected no problem
Rebooted again just for kicks and it worked without a hitch.


Please try it with the just today released v6.17 update. Of course it should again automatically apply on 1st boot.

If it still does not work, please open an issue on GitHub, so we can investigate/debug it there more closely: https://github.com/Fourdee/DietPi/issues

Odroid issues on my C2 seem to be solved…everything working perfectly.

Once again thank you Dietpi Team for all your hard work on this!

That’s great, thanks for your feedback! :slight_smile: