[SOLVED] Dropbear service fails

SSH was working fine until I finished a Wireguard install and rebooted, now I can’t SSH into my local RPI, seems to be an issue with dropbear. I’m on 7.7.3 and when I try to update to 7.9.3, I get more errors complaining about dropbear and the update fails also.

First line of boot message and output of systemctl status drobear.service below

link to pics if image doesn’t show https://imgur.com/a/XFqMs5z

Any advice?

Can you share following

cat /etc/default/dropbear

In worst case you can run dietpi-software and switch SSH server preference to OpenSSH to get SSH access back working.

Sure thing. I’ll post another pic unless you have anotehr way for me to post the output since this is a headless server that I’ve currently connected a monitor and keyboard.

Edit, I’ll try your suggestion to run install openssh

Here’s a link to the pic in the meantime

The issue seems the last line on your configuration file. The KeepAlive yes to be removed

Did you add it manually?

And fixed, thank you joulinar! I’m not sure why this line is in there since I don’t recall typing it in. I do have problems of my ssh connection timing out, but the last time I tried fixing that was weeks ago.

probably you added the value and did not restart the service until now. :thinking:

But if you have issues with closing sessions, you might need to have a look to the client settings.

Will take a look, thanks. And apologies for the late reply, new here and notifications to my email don’t seem to be pushing through. In my profile email is shown as my username and I can’t update it with my email.