solved * DietTinker - default password do not work

Dear all,

I’m trying to install DietPi on an ASUS-Tinker board.
A 16GB card is loaded with BalenaEtcher an the

The ASUS board boots (screen and keyboard) -
The login-Scrren appears :
DietPi v6.33.3 : Update available
hit return to login …

but the combination
root + dietpi
dietpi + dietpi
does not work

I’ve already tried to mount the card under Ubuntu and edit
/boot/dietpi.txt on the SD card and assign a different password.
The changed password does not work either.

what is going wrong here? Does somebody has any idea ?

thx in advance

I remember cases that the sd card was not properly erased and the old contents were still in the /etc/shadow . After the sd was fully erased and the image was written the default password worked.

Thanks for your advice.
Unfortunately without success.

1.) I formatted the card and flashed it again with Etcher…
2.) and used new SD-Card (

same error in both cases when restarting…

I tried all combinations with

User : root, pi, dietpi
Pwd. : root, dietpi, raspberry
on the console and via SSH

… without success

There is no user pi on DietPi. The default password for user root as well as user dietpi is always dietpi. Except, if you set something in /boot/dietpi.txt.

of courese - I know, but in my desperation I tried everything :slight_smile:

One option is to mount and chroot the sdcard on another system, then change the pass.
Other option is to change it in shadow directly.

Did you tried connecting via SSH or local console?


Dear all Thx for your ideas & support.

But the solution was much easier … (or not)
I’m almost afraid to say what caused the problem…

The thing is, the tinker board has its own emmc memory
and another OS was already flashed on this one
but I didn’t know that! :cry:
and while I was trying to enter the default password (because I thought I was booting the new OS from the SD card)
the system was booted into the existing OS with the password already changed …

So Thank you for your support … BR Mike