[Solved] DietPI, pi-hole and unbound: Status "Unkown (12)" (with December 2020, version 6.34)

Hello!

I updated DietPi to version December 2020 (version 6.34), and installed the new “unbound dns” package in side to pi-hole.
Everything went fine, the DNS requests are resolved.

In pi-hole all of my DNS requests have the status “Unknown (12)” now.
Is this the right value? Is with this bundle no more logging in pi-hole possible?

Thanks (for your great work with DietPI),
Mitchel!

Hi,

usually status should be shown as usually. pls can you go inside PiHole > Settings > DNS. Custom DNS should be set to 127.0.0.1#5353. Just hit the safe button again. It should fix it (hopefully)

As well first DNS request could be indeed unknown. However it should succeed later on.

Dear Joulinar,

thanks for your reply. After clicking “save” no more requests were working.
After that I figured out, that I was wrong with my problem description. The real problem is: unbound has not started!

With journalctl -u unbound I found out:

[1608735789] unbound[839:0] error: cannot parse ip address: '.0/24'
[1608735789] unbound[839:0] error: cannot parse access control: .0/24 allow

In the file /etc/unbound/unbound.conf.d/dietpi.conf I found this line:

access-control: .0/24 allow

Changing this line to

access-control: 0.0.0.0/24 allow

made unbound starting.
This is reproducable, by uninstall unbound and install it again.

Now I’m investigating the logging, it seems to work as you described, that the first request of a “unknown” host has the status “unknown (12)”, and the next request of the host is “cached”.

Thanks!

AHH what is your local IP? Currently there is still a challenge that not all private IPs are allowed. Something that still needs to be fixed https://github.com/MichaIng/DietPi/issues/2409#issuecomment-749180419

Ahh…
My IP range is 10.0.0.0/24 .

Edit: Thanks, I use the fix mentioned from MichaIng, see https://github.com/MichaIng/DietPi/issues/2409#issuecomment-749192287
Thank you!

Yes, after some investigating:
1.) the first request has status “Unknown (12)”
2.) after that there is a log entry with “OK (forwared to localhost:5353)”.

Thanks!

ok I marked it as solved even if there is still an open item for next release to provide a permanent fix.