[SOLVED] DietPi Native PC data transfer SLOW


I’m having issues with data transfer from one PC to another. DietPi_NativePC-BIOS-x86_64-Stretch is on one PC and Windows 10 on the other.

  1. Internal HDD to Win10 SSD 91-97MB/s.
  2. Win10 SSD to Internal HDD 91-97MB/s.
  3. Dietpi HDD to Win10 SSD 11.7MB/s
  4. Dietpi HDD to Win10 Internal HDD 11.7MB/s

Using Bitvise to SSH between both results in the same 11.7MB/s transfer rate.
Benchmarked the DietPi drives, both formatted in EXT4

No matter what, sending or receiving from the DietPi PC tops out at 11.7MB/s. I have over 4TB of data I need to get host on this DietPi PC. It would take 48hrs+ to get it all transferred. Way too slow. What am I doing wrong?

Note: The DietPi HDD’s were tested on the Win10 machine before the build so I could verify the speed for transfer. The results were well over 97MB/s on both. However I didn’t take screenshots as I was not expecting to have a transfer issue.

DietPi PC Specs:

ASRock J4205-ITX Intel Quad-Core
G.SKILL Ripjaws Series 16GB (2 x 8G)
128GB SATA III <—DietPi_NativePC-BIOS-x86_64-Stretch
EVGA SuperNOVA 550 G3 80+ GOLD, 550W
HGST Ultrastar 7K3000 2TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Enterprisel Hard Drive x2

I’m also having the exact same issue with my Odroid XU4 running dietpi. I re-imaged the XU4 and its still slow. It didn’t used to be that way. Is this a Windows 10 issue causing the slow data transfer? I thought maybe is was a Samba thing but SSH is no better. Same exact transfer speeds.

I may have found the problem. So it’s my understanding that 11.7MB/s is the speed at which files are transfered over Cat5 or Cat5e even if you are connected to and have Gigabit ports, routers and switches. It could also be the result of an older device on the network that doesn’t support gigabit. In any case, after reinstalling windows 10 pro on my machine, I was able to find and connect to my dietpi shares without issue but the transfer speed is still limited to 11.7MB/s. So…buy all Cat6a cables for every device on my network. If there is still an issue and my controller doesn’t give me back my 1000Mbps/s option (i’ve enabled it before on this machine in particular as it’s my primary gaming rig) then further investigation will be needed. Should have an update later in the week. Any other suggestions/ideas are welcome.

Side note:

I purchased shielded Cat5e 3 years ago for all my dietpi devices, nas box and gaming rig and didn’t have a problem forcing 1000Mbps Full Duplex. Using the same rig, nas and dietpi devices but cant get 1000Mbps connection. Same cables, same router, same switch.

So here’s the skinny.

I have cat7 cable for all my devices (totally forgot). I have a gigabit switch so all those devices can have internet access because the router only has 4 ports. My router (AT&T 5268AC Gateway Router) also has gigabit. However, not all the devices are plugged into the switch, like my PC. It’s plugged directly into the router. Anyway, updated my windows machines gigabit lan to the latest Atheros drivers Still no gigabit option in the drop down via properties. Traded out the cat7 for a cat5e. Nope. Disconnected all devices from the router, bypassed the switch. Connected the PC to the router with cat7. Still no option for 1000Mbps Full Duplex. So, its not the cables, its not my lan port. It’s not the switch. Logged into the ATT router. 4 ports at auto negotiation. Hit the drop down. DAMN. The specs for the router show it supports gigabit lan but that option is also NOT available in the dropdown! Apparently ATT’s firmware update maxed those options to 100Mbps! But I’ve gotten 1000MB/s transfers before.

Ok, here’s the fix. There an upside to this $4!7 show.

I ran one cable from the port #1 of router to port #1 on the switch. That’s my internet for anything connected to the switch. EVERYTHING ELSE gets plugged into ports 2-8 on the switch. PRESTO!!! After restarting ALL my devices I have an average of 111MB/s transfer rate. Took me less than 90 minutes to move 2.5TB of data vs. 22hrs prior. Even SSH through Bitvise is back to its original transfer rates instead of the 11.7MB/s. It should be noted that my PC’s lan port still does not show 1000Mbps option but through the switch I am able to obtain the gigabit communication/transfer between devices.

I’ll raise the issue on the routers gigabit ports with ATT since I used to be able to FORCE the 1000Mbps through the router interface previously. Case CLOSED.

–I hope this is helpful to someone.

Thanks for sharing your solution. While reading the start, I just wanted to say that 11.7MB/s perfectly fits to 100Mbits network, so it’s the network to look at, not the DietPi.

Yeah I also found in cases connecting devices through multiple switches causes issues, so having everything connected to one switch, including the router to serve internet, makes sense here. Not sure about the missing Gbit options, but perhaps the drop-down menus just show the options to “limit” the speed? So e.g. on your Windows device options you should leave “Auto Negotiation” to allow Gbit network and the others are only to limit the speed, if required? It does not make much sense if one machine could force Gbit LAN as it never knows if the others/network support it. So for Gbit it only makes sense to “allow” it instead, or force a lower speed (as the drop-down allows).
And for the router it’s probably the same: Leave on auto to “allow” Gbit LAN or “limit” to 10/100 Mbit