[Solved] Can't boot my rock64 board

Hello,

I just got my rock64 board and because I liked dietpi on my rpi3+ I wanted to install it on there too.

The board wont boot. I connected a tv via hdmi and it shows a bunch of text and then reboots in 10 seconds. it does this forever.

This is the output on the screen https://imgur.com/a/Dugz7CC


The only error I can see is error while loading shared library’s: usr/lib/aarch64-linux-gpu/libiz4.so.1: invalid ELF header

I googled that but couldn’t find anything helpfull.

https://github.com/MichaIng/DietPi/issues/2486

Hmm, this is very early boot stage, so kernel and/or hardware related.

After flashing the SDcard (or now) are you able to check it for errors (run fsck) on another Linux system? Windows can’t do it for the ext4 file systems sadly.

Also try to unplug all external drives/devices to exclude any issues with connected hardware.

Sorry I kind of have forgotten that I posted here.
It is solved now. Someone rebuild the image and linked it to me via github. After that it worked.

Ah great, jep Fourdee redid the Rock64 image some days ago.