Small problems

For the first time using Dietpi, I installed it on a Rapi 4. I wanted root on a SSD-card partition (/dev/sda), and all data on another SSD-card partition. As was suggested, when moving /root to /dev/sda1, I started without any installation of any optimized software. No problem (except that btrfs apparently did not work??).

Then, I tried to move userdata to the other SSD-card partition using the drive_manager, but it was impossible because /mnt/dietpi_userdata did not exist yet. Therefore, I installed some optimized software so that /mnt/dietpi_userdata came to exist. Then, I could move userdata to /dev/sda2 after letting drive_manager mount /dev/sda2 as /mnt/. I prefer to mount it on a folder I call /mnt/data. I looked in fstab, but was told to use the drive_manager. I tried my best, but it was apparently impossible to change the mountpoint-name through the Dietpi interface. So, I changed the mount point name and adjusted fstab, and after a couple of reboot all seem to work.

Altogether, this is of course no catastrophy, though it is a bit clumsy, and for some one who is not an experienced linux-user, I think it could easily have been confusing. Well, I wasted a couple of hours on this fumbling around. If I had installed debian, I would probably not have wasted THAT time.

Never mind, I enjoyed installing nextcloud with my head under my arm. It just worked out of the box. Thank you very much, for your nice work with optimized software!!! I hope you can use my account of these small problems.

yep you could move rootFS as well as bootFS to USB/SSD devices

Maybe you can have a look to the following forum post. There are already a couple of descriptions how to transfer from SD to USB devices

as well it should be possible to flash DietPi directly on an USB device right from the beginning. But honestly I never tested this :sunglasses:

Has it now become feasible to boot a pi4 from an usb drive without having /boot at the SD-card?

See RPi Page

Raspberry Pi 4
The Raspberry Pi 4’s bootcode is stored in EEPROM and can be updated. Support for mass storage boot will be added in a future update.

Known issues

  • The default timeout for checking bootable USB devices is 2 seconds. Some flash drives and rotational harddrives power up too slowly. It’s possible to extend this timeout to five seconds (add a new file timeout to the SD card), but there are devices that fail to respond within this period as well.
  • Some flash drives have a very specific protocol requirement that is not handled by the bootcode and may thus be incompatible.
  • Lack of power can be an issue, so it is recommended to use a powered USB hub, particularly if you are attaching more than one storage device to the Raspberry Pi. If your device has its own power supply, then use that.