Slow telnet response for login

Hi,
The time it takes a rasPi B (1000MHz) to show the login message after a telnet request is consistently around 40 seconds, much longer than I am used to in similar scenarios.
Is there a reason for that? Can we have a faster response? Maybe a problem for us when accessing over 3G.
Thanks in advance.

Are you telnetting into the Pi or from the Pi to an other server?

Hi, into the Pi, from a variety of desktops/laptops just to make sure, same result each time.

Mmm… it’s working fine for me.
https://share.pilovali.nl/2015-10-13_13-05-27.mp4
(Can’t login as root due to security settings, I guess)

I highly recommend NOT to use Telnet because it’s old and very insecure. I recommend that you use SSH, it’s build-in to DietPi and easy to use.

I think it’s caused by your 3G connection. Can you run a ping or tracert?

I have to agree with Pilovali on this one. SSH is the recommended way to access a remote terminal, and, sounds like the delay could be caused by your 3G connection. I’d advise running the ping and traceroute tests Pilovali mentioned above.

All you need to remote terminal access your DietPi system is an SSH client. We provide a pre-setup client for Windows (Kitty), which is available here: https://www.fosshub.com/KiTTY.html
All you will need to do is change the IP address to your RPi before connecting.

Hello,
because of some reasons i need to login to an Pi which is running with Dietpi via telnet connection. How can i install this or what is needed ?By now i get a connection refused → telnet: Unable to connect to remote host

Thanks in advance

Hi,

let me google this for you:

  • Install Telnet SERVER:
apt-get install telnetd
  • Root login via Telnet:
nano  /etc/securetty
  • add at the end the lines:
### telnet root login
pts/0
pts/1
pts/2
  • Then ==>> Restart Telnet Server:
/etc/init.d/openbsd-inetd restart

https://packages.debian.org/jessie/telnetd

http://www.idevelopment.info/data/Unix/Linux/LINUX_TelnetFTPAsRoot.shtml

http://www.technix.in/enable-telnet-linux-server/

Note: Telnet in is insecure protocol and it is recommended that you use ssh server.

WARNING! > Installing telnet on your server makes the server open to an un-encrytpted communications, it’s not recommended to use telnet, use Secure (SSH).

Telnet Server installation

In Debian/Ubuntu

user@techinx$ sudoapt-get install telnetd

>
> How to enable root login from telnet server
>
> Edit /etc/securetty file, In the end of file add pts/0 to enable one telnet session for root. if you need to open more telnet session for root and add more pts/1 pts/2 and so on.
>
> Restart services, you are done!.
>

**[u]Note that this is a massive security threat and may hurt your system[/u]**

wou thank you very much.

telnetd was already installad but didn’t got the login … now it works fine :slight_smile: thank you very much