slow read speed on ssd

My speed check on a Petrol 64GB SSD seemed to give strange results.
The write speed was at least 62MB/s on both 10MB and 100MB tests.
However the read speed was only 3MBS

It is a empty drive formated to ext4 via usb 3.00
Something is clearly wrong, anybody any ideas?

Further update.
Connected a 64GB Petrol SSD in a UASP caddy on a base headless system runnning off an SD card.

On a Linux MInt system drive direct and in USB caddy works well :slight_smile:

In the Pi 4 Using the the dietpi menus
I can mount the drive (/mnt/ssd) when its is formated (prior to installation) :slight_smile:
Drive check does not show any errors. :slight_smile:
Formatting the drive never completes. :cry:
On a ext4 partition write is a good speed, read is zero or 3MB. :cry:

Using the Dashboard
Dashboard crashes when trying to use the file browser to view /mnt/ssd & requires a reboot to get dashboard working again. :cry:

Using ssh as root
Everything seems ok - can read and write files to the ssd :slight_smile:

I’m not sure where to start, something is clearly wrong.
Can anybody point me in the right direction?

you could try to check kernel error messages

dmesg -l err,crit,alert,emerg

Thanks Joulinar,

The only error that comes up is about the bluetooth chip ,“Unable to determine no of FB’s. Disabling driver”
which I assume is irrelevant to this issue.

did you tried different USB ports and or cable? Does the drive used an own USP?

maybe you have another idea why the drive is working slow

Think I’ve found the issue, although it does suprise me and does not seem to make sense

On a brand new installtion SSD worked via a powered hub, without the hub it had read but not write issues suggesting a PSU issue although the PSU appears stable and more than capable of the job.

However, intuatively I would expect it to be the otherway round with issues on write rather than read if any .

As an alternative I can run a 2.5" HDD directly without a hub and no issues or drop in speed, I would have thought that takes more current.

the upshot is looks like I can only run the SSD via a USB hub which is a disappointment.

means using a powered USB hub solved the issue?

unfortunately yes

basically we recommend to use a dedicated PSU or powered hub for external disks.