Sleep and CPU high after upgrade to 7.7.3 in PC x86_64


I have upgraded to 7.7.3 in the dell laptop I use with DietPI (has been working great the last 2 years). The first thing I noticed after the reboot is that I can’t access by SSH. The laptop was always sitting with the lid close I realised after that a while that the laptop is in the sleep mode (the lid is closed because the screen is broken and anyway I use it as a server). I believe I remember setting some parameters so the screen turns off after the lid is closed (it was remaining on) but I can’t remember if I tweaked the settings for the sleeping mode.

Another thing I realised is that the laptop was super super hot. Now if I have the lid open it seems to run normal (a bit warmer than before but usable) but if I turn on the laptop and close the lid, dietPi continues to boot and actually starts all the services, but after going to sleep mode there’s some process that makes the CPU going hot.

How can I fix these issues? Is there a way to rollback to a previous version?

Usually DietPi scripts don’t have such effect as they are simple bash scripts. Probably some apt packages got updated, consuming higher load now? You could have a look to htop to check what is running and how much resources are consumed by the processes. Question regarding rollback, yes you can if you have done a backup before.

Thank you for replying. About the sleep mode when the laptop lid closes. Do you have any tips or workaround?

The DietPi version has no influence on this.

I’m not sure how the sleep mode actually works, if it is an ACPI call or whether this is something that only works from a desktop session via upower or xfce4-power-manager packages. Definitely this is not something I’d expect to work in the middle of a boot sequence, at least I’d never do that and also it doesn’t work on any other OS I’m aware of. So that “dietPi continues to boot and actually starts all the services” is something I’d expect and rate as correct behaviour to not break boot in the middle just because the lid was closed.

Since it is a server, I guess you don’t have a desktop install, do you?

Actually a good question how to disable screen output on an x86 Linux server (when you cannot simply detach it). I guess GRUB has some setting for this, but I’d also need to have a look.

Just to assure I understand the goal correctly: The screen should be off (makes sense as this explains very well hot temperature with closed lid) but the sleeping mode is actually something you do not want but what happens automatically now after a while?

No, I don’t have a desktop install. I have the sever install.

Now that you’re saying it. I remember that there was some GRUB command I needed to add to the defaults so the screen turns off completely after boot. How can I do that the the older boot options remain after the upgrade? I don’t recall is this but seems to be the answer to have the screen off

The sleep function was managed somewhere else under /etc . I think here

The GRUB settings in


won’t be touch by any kind of update/upgrade I’m aware of, definitely not by DietPi and not by any official Debian package (which do have strict rules for files in /etc).

Actually great to know about this option. I’ll add this as a “headless” mode for x86_64 systems by times :slight_smile:.

If the lid closing is managed via systemd-logind, assure that it is running and fully functional:

systemctl unmask systemd-logind
apt install libpam-systemd
systemctl start systemd-logind