Same Chromium issue in two separate devices

Hi all,
I am running DietPi 8.1.2 with Chromium in kiosk mode on a Pi Zero W2 and a 3B+.
They are displaying a web page (different one on each device).
Both of them, on the same day (at some point last week) start showing the exact same error:

Both devices have been running flawlessly for quite some time, and I do regular updates.
Strangely enough, this happened without me changing anything or even applying an update of any kind.
How can I fix this?

Just reinstalled everything from scratch, with the same result.
Any ideas?

does this happen on all web sites (like or just some specific one?

Hi Joulinar

It happens with any website. The two Pi’s are programmed to display two different websites, and the error appears in both of them.
One is a local website and the other one is a public website loading from a web host.

how do you start Chromium? In kiosk mode or from a desktop environment? Did you tried other web sites or just the 2 you have set up?

I start it in Kiosk mode.
Loaded the microSD card with the ARMv7 32-bit image.
After installation finished, I installed Chromium using

sudo dietpi-software install 113

No other software is running apart from the SSH server.

Then I run:

sudo dietpi-autostart

and chose the page I wanted to load.
Rebooted, and got what you see in the screenshot.
Two different RPI’s, different page on each.
Also tried other pages (i.e. Same result.
I’m completely baffled!

I would like to test but will take some days as I’m out.

No problem Joulinar , I’m in no rush.
Thank you

Hi Joulinar
Did you get a chance to have a look?

I’m still on a trip without access to my test lab

Oh, ok, talk soon then!

Ok Joulinar , I posted this question on Reddit and someone else found the same problem.
It turns out that it has to do with a recent Chromium update.
The kind person who found this said that the problem is caused by hardware acceleration and once he disabled it the problem went away.

Does anyone know what terminal command disables Chromium’s hardware acceleration?
I found this page with many helpful commands, but I don’t know how to implement it into DietPi.

Any ideas anyone?

I found this worked for me (PiZ2):
nano /var/lib/dietpi/dietpi-software/installed/
and add --disable-gpu to the end of the CHROMIUM_OPTS

Chromium now loads properly for me :slight_smile:

Cross linking the GitHub issue:

Solved with: