Samba share

Good morning everyone,
My name is Luca and I have been using Dietpi for quite some time. I have this problem: in Windows 11, in the network connections, I don’t see the samba shares. To access the shares I have to type \server and in this way I can access.
With OMV I don’t have this problem and the name of the shares are visible among the network resources.
Thanks in advance to those who can help me to solve this problem.
Regards

Did you set a workgroup in the smb.conf?
Do not forget to restart samba after you made changes in the config:
sudo systemctl restart smbd.service nmbd.service

Or you just could map the share as a network drive, then it will be constantly visible in file explorer (I assume this works as well in windows 11 as in windows 10)

Thank you for your answer.
Yes, I have set the same group in both Dietpi and Windows.
I always restart the smbd and nmbd server after the changes.
If I map the shares as disk everything works perfectly.
My problem is that I don’t see the name of the computer (Raspberry + Dietpi) in the network resources of Windows.

Here my [global] smb.conf

[global]
        workgroup = DODO
        server string = %h server (Samba, Server)
        dns proxy = no
        log level = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        logging = syslog
        ;logging = file
        panic action = /usr/share/samba/panic-action %d
        encrypt passwords = true
        passdb backend = tdbsam
        obey pam restrictions = no
        unix password sync = no
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        pam password change = yes
        socket options = TCP_NODELAY IPTOS_LOWDELAY
        guest account = nobody
        load printers = no
        disable spoolss = yes
        printing = bsd
        printcap name = /dev/null
        unix extensions = yes
        wide links = no
        create mask = 0777
        directory mask = 0777
        use sendfile = yes
        aio read size = 16384
        aio write size = 16384
        time server = yes
        wins support = yes
        multicast dns register = no
# Special configuration for Apple's Time Machine
        fruit:aapl = yes
# Extra options
        min receivefile size = 16384
        getwd cache = yes

for what reason you like to see the “computer” on network resources in Windows? It should be fine if it is mounted.

you’re right.
In my network I have several devices that I see in the computer resources (modem, decoder,etc) and I would like to see also the computers that I use as servers (raspberry - dietpi).
With OMV I see the computer (raspberry + OMV) in the Windows resources but I can not do the same with Dietpi.
I wonder why

This one solved it on my test system https://devanswers.co/discover-ubuntu-machines-samba-shares-windows-10-network/

Thank you so much!
You have solved my problem.
Your solution works great!!!
Thanks again
Luca

I had a look to the Github repository for the wsdd tool. Actually it’s quite simple. Just add the repository and install wsdd via apt install

https://github.com/christgau/wsdd#debianubuntu

I have two raspberry pi, both with the latest version of Dietpi. I have updated both with the procedure you mentioned.

I have the following situation

  • Windows 11 client - I see both raspberry pi’s in the network resources and access them perfectly.
  • Manjaro 21.2.2 client - I don’t see the computers in the network resources but only if I type smb://IP_of_the_computer I can access them
  • Mint 20.3 client - I only see one raspberry pi in the network resources while to access the other I have to type smb://IP_of_the_computer

What could be the cause?
Regards
Luca

Solution above is dedicated to Windows client. Nor sure what Manjaro or Mint needs to detect Samba server on local network.

Thanks!
It works perfectly with Windows 11.
Luca

Thank you. This is exactly what I was looking for.

Had my pi assigned to a drive but I had to reset the assignments and was wondering why it was not showing up in network.

Interesting discussion, I was just trying to do this the other day. I would like to make my Dietpi box discoverable to my network. I was reading the instructions and there is a part where it says:

There are user-maintained packages for which you need to add the repository to /etc/apt/sources.list.d with a file containing the following line

deb > https://pkg.ltec.ch/public/ > distro main

Replace distro with the name of your distro, e.g. buster or xenial (issue lsb_release -cs if unsure). After an apt update you can install wsdd with apt install wsdd.

I don’t understand how to add the repository. Is there a command to do that or should I edit the sources.list.d file?

simply create a new source file

nano /etc/apt/sources.list.d/wsdd.list

add following (assuming your are on Debian Bullseye)

deb https://pkg.ltec.ch/public/ bullseye main

and run following to read the list

apt update