SabNZBD not running latest version (stable)


I keep getting a message when logging into my Sab portal that there is now version 3.0.2 out as stable, but my version of dietpi (running on raspberry pi 4) is only on 2.3.9

Is there a way to update this?

Thanking in advance for any guidance.



many thanks for your. You could run dietpi-software reinstall 139. This should update you to version 3.0.2 + python3. As this quite some big changes, I would recommend to perform a DietPi-Backup before.

thanks for that, I will do a backup and try the reinstall soon. I have noticed tonight though that sonarr has stopped writing to the cifs shares inside /mnt, they can create a partial file, but are unable to write the complete file. This has broken it seemed since updating recently, have tried to change the service so that sonarr runs as user dietpi (this is the user / password configured in fstab and also the user setup on my NAS for the connection) but this still says access denied when trying to write data (applications seem able to read all the data though).

Think I will hold off on updating SAB until i resolve the file permissions issue. I have downloaded over 30TB of data successfully, its only about the last 700 files which have not worked which is why i think it coincides with update/upgrade commands.

is anyone able to give me any pointers on how this might be resolved, i will switch the service config file back so its starting up as sonarr again, but I dont know what password this user has so I cannot create a matching account on my NAS for authentication.

Ok, following the threads on github, it appears that upgrading to v3 of sonarr is the fix for the problem with it not writing files, has also worked for me.

Will run the reinstall for sab and update how that has gone

Since a while there is an open issue regarding Sonarr not being able to write to CIFS mounts

Issue was/is with mono v6 if I’m not mistaken. A workaround was to use Sonarr v3. But not sure if this is still valid.

Anyway, application user sonarr has no password because it’s a non-interactive user. Means, it’s used on the service only and can’t be used to login to the OS. The CIFS mount themselves is done by the user you specified during mount process. Usually it should be visible in /etc/fstab. You should see something like this in your file:

... /mnt/samba cifs username=xxx,password=xxx ....

on DietPi access is managed through user group dietpi. Means, application user sonarr would need to be member of user group dietpi. This can be checked by running groups sonarr

root@DietPi3:~# groups sonarr
sonarr : dietpi

Thanks for the reply, the issue was resolved by upgrading to sonarr v3, the sonarr user/service account in indeed a member of dietpi group and the mapping in fstab uses the dietpi user to map the share as below.

//            /mnt/TVShows      cifs username=dietpi,password=***,iocharset=utf8,uid=dietpi,gid=dietpi,file_mode=0770,dir_mode=0770,vers=3.0,_netdev,nofail,noauto,x-systemd.automount

everything appears to be filtering across to the correct destination now, just need to give it a bit of time as there were quite a few files completed which couldnt be moved due to the error.

because of this, will work on upgrading SAB in the morning (6 hours of downloading still to go) as will have an empty download queue by this point.

Thanks for the help, amazing support on dietpi, cant believe how much easier things are with this o/s over other pi installs.

1 Like

If I run dietpi-software reinstall 139 and am already at python 3.9 (just upgraded to bullseye yesterday but need to get sab updated), will that command only upgrade sab? Thanks!

Basically, all required software will be reinstalled. If they are already on target version, they will be skipped.