RPiPlay and DietPi

I have tried to install RPiPlay on DietPi, tried on a Raspberry 3B and 3B+. RPiPlay (GitHub: https://github.com/FD-/RPiPlay) is an audio and video receiver for AirPlay, and would be a great piece of software to be run on an “headless” system with HDMI output, since ShairPort only woks with audio. The only issue here is the compatibility with only Raspberry hardware.

Right now I managed to get audio streaming to work over HDMI with both a MacBook and an iOS device, but I’m having some difficulties for the video. Before compiling the project, you’ll need the ilclient library, which is part of the raspberrypi/userland repository (https://github.com/raspberrypi/userland).

This software seems to run independently from X11 and desktop environments, because installing and uninstalling them doesn’t solve my issue (I think it uses the framebuffer directly).

My issue is the unavailability of the video stream: even if you set the background to be black on RPiPlay, with the -b on option, the display still shows the console with the program output. This happens also when starting the program with a custom autostart file, via ssh or through the windowed terminal in LXDE. This software works on Raspbian and Raspbian Lite, but I have read of people running it on a simple Debian bistro on a RPi 3B. Device connection works, as confirmed by the audio stream and the console output that displays a reasonable video delay.

I used it in the past, and with a good network it works quite well, the only thing that isn’t supported yet is video streaming from the web, because Apple implemented it in a way that the receiver directly connects with the source, leaving the iOS device only to work as a remote control.

Does anyone have any ideas/suggestions that could prevent this software from giving video output on DietPi? (Could be a good addition to the software list).


Hi Riccardo,

I tried installing RPIPlay on a DietPi as well on a Pi4 albeit unsuccessfully. I did not even get to the point of discovering an AirPlay receiver on any of the devices at home. The RaspberryPi Github link you specified is different from the one I used to download the iClient. I wonder if that may have caused the issue. I used this one: https://github.com/raspberrypi/firmware

I’ve extensively documented the issue here: https://github.com/FD-/RPiPlay/issues/129. I hope you’ll review it to offer your thoughts.

Ok, from what I have read you got a black screen, which is what I need to have a completely working system (for video), since the logs show that my devices successfully transmit frames (along with audio, which works for me) to the Pi. Right now I don’t have much time to play with my Raspberry Pi because of some university exams, but I’m looking forward to try some new things (such as using the firmware repository) for this software this summer.