RPI3-waveshare32-white screen of brilliance-Diepti V152

Hi all
First of all, I would like to congratulate for this image and for each of you that bring this initiative to life. It’s very good works.

I have a RPI3 with waveshare32 but I still have my screen in white after a fresh installation Dietpi V152.
I must to tell you I d’ont have a lot of knowledge :stuck_out_tongue: and I hope you can help me.

# /DietPi/dietpi/misc/rpi_boardinfo

  - RPi Board Info - 
 Revision         |     a22082
 Released         |     Q1 2016
 Model            |     3 Model B
 Memory           |     1024 MB
 Manufacturer     |     Embest, China

# cat /proc/version
Linux version 4.9.27-v7+ (root@DietPi) (gcc version 4.9.2 (Raspbian 4.9.2-10) ) #2 SMP Thu May 11 18:50:36 UTC 2017

After updating everything, I installed:

  • DietPi-config → Display Option → LCD Panel addon: waveshare32
  • DietPi-Cloudshell (to test the LCD)
    Remark: I can see the Cloudshell in the hdmi output but not in the LCD.

So, according this good help I found some difference: https://github.com/Fourdee/DietPi/issues/409

  1. I can’t see the fb_ili9340 and fbtft modules but yes the ads7846 the driver for touch-pressure measurement.
# lsmod
Module                  Size  Used by
evdev                  12423  0 
joydev                  9988  0 
ads7846                13656  0 
hwmon                  10552  1 ads7846
brcmfmac              222798  0 
brcmutil                9092  1 brcmfmac
cfg80211              542989  1 brcmfmac
rfkill                 20832  2 cfg80211
snd_bcm2835            24427  0 
snd_pcm                98629  1 snd_bcm2835
snd_timer              23904  1 snd_pcm
snd                    70032  3 snd_timer,snd_bcm2835,snd_pcm
i2c_bcm2835             7167  0 
w1_gpio                 4818  0 
spi_bcm2835             7596  0 
wire                   32619  1 w1_gpio
bcm2835_gpiomem         3940  0 
cn                      5889  1 wire
fixed                   3285  0 
uio_pdrv_genirq         3923  0 
uio                    10268  1 uio_pdrv_genirq
i2c_dev                 6913  0 
i2c_bcm2708             5994  0 
fuse                   99603  1 
ipv6                  406388  20

So I make apt-get install xserver-xorg-video-fbdev and xserver-xorg-video-fbturbo. But I still the same.

# dmesg
[    2.317739] i2c /dev entries driver
[    2.861045] systemd-udevd[170]: starting version 215
[    3.160507] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    3.170064] Driver for 1-wire Dallas network protocol.
[    3.175039] w1-gpio 4.onewire: gpio pin 4, external pullup pin 1, parasitic power 0
[    3.175077] w1_add_master_device: set_pullup requires write_byte or touch_bit, disabling
[    3.484357] EXT4-fs (mmcblk0p2): re-mounted. Opts: discard
[    3.517804] usbcore: registered new interface driver brcmfmac
[    3.579167] spi0.1 supply vcc not found, using dummy regulator
[    3.589695] ads7846 spi0.1: touchscreen, irq 183
[    3.592782] input: ADS7846 Touchscreen as /devices/platform/soc/3f204000.spi/spi_master/spi0/spi0.1/input/input0
[    3.657542] brcmfmac: Firmware version = wl0: May 27 2016 00:13:38 version (r640327) FWID 01-df77e4a7
[    4.106460] systemd-journald[133]: Received request to flush runtime journal from PID 1
[    4.515520] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    4.515549] brcmfmac: power management disabled
[    4.578145] brcmfmac: power management disabled
[    5.130472] brcmfmac: brcmf_cfg80211_escan: Connecting: status (3)
[    5.130485] brcmfmac: brcmf_cfg80211_scan: scan error (-11)
[    5.245548] Adding 55292k swap on /var/swap.  Priority:-1 extents:2 across:79868k SSFS
[    5.857595] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[    5.873766] w1_master_driver w1_bus_master1: w1_search: max_slave_count 64 reached, will continue next search.
[   24.768180] brcmfmac: power management disabled

Ok, so I control all the file should be applied and script.

# ls /boot/overlays/waveshare32b.dtbo

# cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=ee614650-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait fbcon=map:10 fbcon=font:ProFont6x11 logo.nologo fbcon=map:10 fbcon=font:ProFont6x11

# cat /DietPi/config.txt
#Modifcations to /boot/* files, will not be saved when powered on.
#Please ensure you edit from the DietPi-RamDisk location /DietPi/*

# uncomment if you get no picture on HDMI for a default "safe" mode

# Set to 1 if your display has a black border of unused pixels visible

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus

# Rotation

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#-------RPi Camera Module-------

#-------GPU memory Splits-------

#-------Max USB Current -------

#-------Disable Ram temp refresh every 500ms---------------

#-------Disable Pi Splash screen on boot-------------

#-------Remove dedicated pll for PWM audio -------







#Note To Self, NEVER enable L2 cache, breaks most X based applications that were not compiled with L2 cache enabled.

#Waveshare 32 LCD

# ls /etc/X11/xorg.conf.d/
99-waveshare32_calibration.conf  99-waveshare32_xorg.conf  99-waveshare32_xorg.conf.backup
# ls /usr/share/X11/xorg.conf.d/
10-quirks.conf	40-libinput.conf  99-fbturbo.conf

If I check in the 99-waveshare32_xorg.conf I always have the hdmi even if I change /dev/fb1 or /dev/fb0

# cat /etc/X11/xorg.conf.d/99-waveshare32_xorg.conf
Section "Device"
Identifier      "FBDEV"
Driver    "fbturbo"
Option          "fbdev" "/dev/fb1"

Option          "SwapbuffersWait" "true"

And If I try to install modules missing

# insmod fb_ili9340
insmod: ERROR: could not load module fb_ili9340: No such file or directory
# insmod fbtft 
insmod: ERROR: could not load module fbtft: No such file or directory

Thank you very much for your help.

Hi fido,

tested with the same result.

Created a github tiket for this issue: https://github.com/Fourdee/DietPi/issues/1048