Rpi3 - v6.8 USB boot - RootFS too small

Hey guys,

Just flashed 6.8 to a usb drive (32Gb) and went to install it on my RPI3 which I have used previously with USB and DietPi without a hitch. However, with this new version it fails to resize the partition or expand it, so when the DietPi update to 6.9 tries to go I get an error about the partition only being 60mb’s and needs atleast 500mb of space. I have tried reflashing several times and nothing seems to get me beyond booting and to the update start, then failure. I haven’t tried it on an SD card, but previously had no issues with DietPi and USB on this particular unit until now. Let me know if there is any helpful debug information I can capture.

Thanks for the report.
Note that v6.9/testing branch is on active development and can cause issues at any time. If you have a production system, I highly recommend to stay with v6.8 until v6.9 is release/moved to master branch.
But if you want to help testing, of course you are welcome to do that :smiley:!

Could you paste the content of: /var/tmp/dietpi/logs/fs_partition_resize.log

If you boot the system from USB drive, the resize script should also try to resize USB partition: https://github.com/Fourdee/DietPi/blob/dev/rootfs/var/lib/dietpi/services/fs_partition_resize.sh
findmnt / -o source -n should show the /dev path of your USB drive root partition. I hope is has the scheme /dev/sda2 or similar?