I accidentally updated the kernel on my pi4 to 5.4. It broke a few things that the foundation admits to. When I tried to downgrade I found out that rpi-update is not included in DietPi.

Is there another way?
I still have a copy of DietPi on a SD card that I used to make the Pi USB/HD bootable; What would I need to copy from it and not lose all my setup stuff.


many thanks for your request. You simply can install rpi-update if needed

apt install rpi-update


Yeah, I installed rpi-update from apt. Problem is I am running headless and the ethernet connection crashes too frequently to run it!

So, what I did was edit cmdline.txt and started using the SD card to boot and the HDD for root. Worked good until I had to use DietPi-software to add an app. That triggered a full-upgrade which reinstalled kernel 5.4.

Kernel 5.4 turns my Pi4 into a boat anchor by killing at least 1 core and doing something to the USB and ethernet. Oddly, I have 2 PCs that are running kernel 5.4 just fine.

Yes dietpi-software is going to trigger apt update && apt upgrade, always. Looks like there are some issues with the new Raspberry OS Kernel 5.4. You could try to exclude packages from being upgrade by apt

apt-mark hold <package>

Be prepared! Everybody with a PI4 that downloads new software will be killing their machine until the new kernel is fixed. There does not seem to be much urgency at the foundation, they knew about the problem several days before they pushed it. Now all you get is warnings to not pester them about it.

I don’t know if the problem extends to the Pi3. It seems to have something to do with USB 3.0/ethernet.

There are more issues on the new kernel. Honestly I’m don’t understand why the foundation released such a buggy kernel.