RPi not booting after Hotfix

Hi Guys,

I recently applied a hotfix patch (which required a restart). Before restarting though, I also tried to update Home Assistant on my DietPi installation. It looks like before that completed, I lost connection through SSH. I managed to reconnect and then tried to initiate a reboot.

After this reboot, my RPi is not starting up again.

I really would like to avoid reloading everything from scratch if possible - do you have any suggestions on what I can do to troubleshoot?

Any chance to connect a screen to see what happens during boot?

It looks like there is a disk issue.


Dependency failed for /boot
Dependency failed for local File Systems
Dependency failed for File System Checking on /dev/disk/by-partition…

It looks like I can get into a maintenance mode where I can run fsck. I see there is at least one bad block.
Is it my best bet to run fsck? (I see an option to “Force rewrite”, but I’m not too familiar with what is actually going on when I run this and if this is the best bet to try save what I have.

Is this an SD card? Or an external disk connected via USB?

SD card

might be some damage on the SD card. Do you have another Linux that could be used to check the SD card?

Yes I do. I’ll have a moment to check this tonight. Assuming there is a bad block or some other disk error, is there any way to try recover even part of the contents?

theoretically you try to recover the blocks. Maybe MichaIng could help with this before doing something wrong :wink:

I was able to access the partition using one of my other Linux machines. The disk utility allowed me to check for errors and repair them.
For now all appears to be working again.

I’ve done a backup and will probably look at moving the installation to another card as I’m a little worried that this card is busy failing.

ok perfect, good you managed the data corruption. Bevor switching to another SD card, you could think of a USB pen stick. I’ve moved all my RPI devices to boot from SanDisk Ultra Fit 16GB USB 3.1 FlashDrive. Just as an idea.

Is there a good guide out there to do this?
I wasn’t aware that you could boot form USB

what kind of Raspberry Pi you are running?

Model 3 B+

I also have a Pi Model B (but not sure I’ll do this for this old model)

there is an official documentation on how to enable USB mass storage boot. The steps to activate debepds on RPI model. https://www.raspberrypi.com/documentation/computers/raspberry-pi.html#usb-mass-storage-boot

Raspberry Pi 3B+
The Raspberry Pi 3B+ supports USB mass storage boot out of the box.

From DietPi side you simply need to flash the image directly on your USB stick instead of the SD card.