RPi-Monitor in DietPi v.8.0 and v.8.1 doesn’t show CPU Temperature.

this is an issue of RPI Monitor themselves and has nothing to do with DietPi. https://github.com/XavierBerger/RPi-Monitor/issues/374

When I had older version of DietPi it worked normally.

as you can see in the Github link above, it’s an issue of RPi Monitor.

Anyway this should fix it (hopefully)

G_CONFIG_INJECT 'dynamic.1.postprocess=' 'dynamic.1.postprocess=$1/1000' /etc/rpimonitor/template/temperature.conf
systemctl restart rpimonitor.service

A little bit OT:

I tried yesterday some workarounds mentioned at github. Non of them worked.
In the interactiv config

rpimonitord  -i

everything works fine, when trying to add the temp config manually.
Even with

dynamic.1.postprocess=sprintf("%.2f", $1/1000)

(btw sprintf("%.2f" is for rounding the value to two digits)

But the web panel shows always Null, so I guess there is somewhere a bug between grabbing the data and the output to the web panel.

setting it to dynamic.1.postprocess=$1/1000 is working for me on RPi3B+ 32bit and RPi4B 64bit.

What device you are running Jappe

Ok I testes your workaround and now it works, :rofl:

G_CONFIG_INJECT 'dynamic.1.postprocess=' 'dynamic.1.postprocess=$1/1000' /etc/rpimonitor/template/temperature.conf
systemctl restart rpimonitor.service

but why??? :smiley:

I also set minmal showm Temp for the graph to 30°C, bc my Pi runs cooler than 40°C

web.status.1.content.1.line.1=JustGageBar("CPU Temperature", data.soc_temp+"°C", 30, data.soc_temp, 80, 100, 80)

Ok I testes your workaround and now it works, > :rofl:

G_CONFIG_INJECT ‘dynamic.1.postprocess=’ ‘dynamic.1.postprocess=$1/1000’ /etc/rpimonitor/template/temperature.conf
systemctl restart rpimonitor.service

> but why??? > :smiley:

Did you restart the service after applying the change?

It looks the challenge is with rounding to 2 digits. There it is failing. If we remove it, it's working.

Yes, I restarted, but I guess I had a typo somehwere.

I also tried now

round(($1/1000, 2)

but it gives also Null.

Another working solution with a little bit better “formatting” (No decimal places at all)


I think it’s okay for the temp of a CPU

So if anybody wants the temp shown without any decimal place:

G_CONFIG_INJECT 'dynamic.1.postprocess=' 'dynamic.1.postprocess=floor($1/1000)' /etc/rpimonitor/template/temperature.conf
systemctl restart rpimonitor.service

(sry for the spam posting :slight_smile:)

Just found another “bug” (it’s just a typo) in


at line 21:

web.status.1.content.9.line.1="<b>/sda1</b> Used: <b>"+KMG(data.usbhdd_used,'M')+"</b> (<b>"+Percent(data.udbhdd_used,data.usbhdd_total,'M')+"</b>) Free: <b>"+KMG(data.usbhdd_total-data.usbhdd_used,'M')+ "</b> Total: <b>"+ KMG(data.usbh>

The Percent() function doesn’t work because of


instead of


I couldn’t find usb_hdd.conf at the github repo, so I’m not sure how to adress this issue there.

we do some more fixing on this now. I will include the issue you found.


Many thanks for reporting guys, should be all fixed now for DietPi v8.1, and we also restored the max 2 decimal places for the CPU temperature :slight_smile:.

I have another strange behaviour: rpi Monitor says there are two packages upgradebale, but this is not true, the system is up to date.
The packages are libcryptsetup12 and epi-eeprom.
It also didn’t show the last upgradable packages (some samba stuff), it’s somehow stuck to this two.
Everything else works fine.
Yesterday I deactivated the internal webserver of RPi momitor and the page is now serverd by Lighttpd. Since then this happens.

I switched test-wise to internal server and cleared my browser cache, but it still shows “2 upgradable packages”

Next hint:

The template version.conf grabs the data from /var/lib/rpimonitor/updatestatus.txt and this file doesn’t exist on my system.
The script /usr/share/rpimonitor/scripts/updatePackagesStatus.pl which should write to the updatestatus.txt also doesn’t exist.
I reinstalled RPiMonitor and now everything is working!

I also restored my system yesterday, I guess something went wrong when restoring RPi Monitor?!

Cheers :slight_smile:

you could try to grab the raw script directly from their GitHub