RPi - A start job is running for Hold

I searched the boards and did not find a previous post…

2 different Rpi models with 2 different memory cards > same problem.
First time boot…select ownCloud to install (tried Nextcloud also). Installation seems to go okay. Reboot and get: " A start job is running for Hold…" with unlimited wait time. I can’t find a way to get out. I don’t know what I missed on first run.

Pulling power makes the Pi think the software failed to install, and is hosed.

Any advice?

Can you please try to edit /boot/cmdline.txt and add logo.nologo (separated with 1 space) to the end of the line?

Thanks, for the reply. I did finally get it running on the older PI. A hard reset (pulled the power) made it work. I am now struggling with mounting a USB HDD. I may circle back to this later.

In my experience this error relates to the sytem trying to mount a drive that isn’t there or has a faulty file system or some other error.

How I have fixed it is to comment out the offending drive in /etc/fstab (if all else fails by taking out the SD card and editing on another Linux machine) and then reboot and try to find the error on the drive that won’t mount.

They may be other reasons for this error, I’m not sure.


I added a new 2TB WD 3.5" drive to my Rpi3 last evening, and now I’m having this issue. What a pain. It looked like the format process went OK, and I had begun copying over some directories to the new drive, but then I noticed only a couple of the files I was trying to copy made it to the new location…so something was screwed up. Guess I’m going to have to find a way to edit fstab now. Drat!

nicheplayer Bobby johnvick
Found the reason for this behaviour on boot:

  • On Raspbian Stretch somehow the mountall APT package is marked as “required”. This is strange since nothing requires it and it has been even removed from Debian since Stretch: https://packages.debian.org/search?searchon=names&keywords=mountall
  • mountall again depends on plymouth (a splash screen implementation) which causes the issue.
  • Packages that are marked as “required” by the repo will never be autoremoved, thus survive our image preparation process.
  • Even worse is that mountall depends as well on initramfs-tools which is as well not required on RPi.
  • RPi comes with its own splash screen and initramfs implementations, so I consider it as Raspbian repo bug that mountall is marked as “required” thus two with RPi implementations conflicting packages are tied to Raspbian systems…
  • However it’s easy to solve:
G_AGP mountall
  • I as well updated our RPi image which has these packages actively purged with the updated DietPi-PREP script.