RPI 4 won't boot with usb hub


I am using a RPI4 with an external HDD. There were some power issues so I decided to add a powered USB hub between the rpi and the HDD. To my surprise the system won’t boot when the hub is used. Do I need to do a fresh install when adding an USB hub?


did you tried connecting the HUB to all 4 different USB ports USB2 + USB3?

Hello Joulinar,

not yet, just tried the USB 3 port so far. The system also won’t boot when no HDD is attached. I have no micro HDMI cable etm so I ordered one and will take a look at the shell as soon as it arrives…

well if there is no HDD connected, you would need to use SD card :wink:

There is of course a sd card inserted. :slight_smile:

Puhh it should boot with SD card. Did you removed the USB hub completly? Any a activities on the LED?

Just got the HDMI cable. When I add the usb hub to the rpi and add the hdd to the hub the rpi shows those messages:

vc_vchi_sm_init: failed to open VCHI service (-1)
[vc_sm_connected_init]: failed to initialize shared memory service

The hdd is powered and I can hear i clicking when rebboting the rpi.

Edit: just found out that those messages are just warnings. The rpi does boot and also the drive is working - at least when the hub itself is not powered. The drive reports some inode errors so I will try to fix it and see if everything works afterwards.

Edit 2: the rpi is working fine, no isses at all. I just have no idea why I could not connect to the shell after adding the usb hub. Sorry to disturb you!

yes these 2 messages can be ignored safely and we are going to hide them on next release anyway as they are causing to much confusion :slight_smile:

Do you still have monitor and keyboard attached? Your system is booting and you can login locally? Just SSH access is not working?

The system is working without keyboard now, even remote access is working again. I have no clue why it did not work last time when running headless.

I added the powered usb hub because the data in my external drive gets corrupted when the drive has to copy and write big data. Sadly the usb hub doesn‘t solve the issue, got some new inode errors within an hour. I just attached the drive to my windows client and checked the SMART values, everything looks good - but the issue persists. Do you have an idea what could mess up my data? Today nothing but NZBGet was running and suddenly the log was spammed with messaged that there is an issue accessing some files NZBGet has created some minutes before. I also reformarted the drive with no success.

what is the error message exactly you are facing?

As well you could have a look to kernel messages

dmesg -l err,crit,alert,emerg

Hey again,

it took some time but I was able to resolve my issues. It seems that it was indeed an issue with the power supply of the external 2.5 drive, even when using an active USB hub. I then replaced the drive with an external 3.5 drive and didn’t have any issues so far, even with high load. There is also a performance gain with the other drive, so I will not try to make the smaller drive work with the rpi any longer.

Thank you for your help!

good you found it and it’s working now :slight_smile: