RPi 4 Samba LAN Copy Speed is Terrible

Copying a file, let’s say 10GB is horribly slow on my system.

The speed starts around 30-33MB/s and then drops all the way down to about 3-4MB/s after copying for about 5 minutes.

My setup:

Samsung 1TB USB 3.0 HDD → Raspberry Pi 4 → Cat 5e Ethernet Cable
→ Asus AC68U Router → 3Ghz Wifi (ac) →
→ Intel Wireless AC 9260 160Mhz (ac) → Dell XPS 15 Samsung Nvme SSD

That’s the total path from my Raspberry Pi to my Laptop.

Why is the speed so slow?

The temperature of the RPi 4 doesn’t ever go above 44C. I have a Noctua fan cooling the device and an aftermarket heatsink so idle temps are normally 36C and never go past 40C when downloading something and about 42C when copying.

I really expected the 1.5Ghz CPU and USB 3.0 ports on the RPi 4 to be able to handle speeds up to even 50MB/s but this is really quite bad. The burst speed is okay if I am copying over only about 1GB but anything higher than that and the speed drop over time means it’s not feasible at all.

The above screenshot shows a copy speed of about 10MB/s but trust me when I say that it gets all the way down to 3MB/s if I leave it long enough. Unmounting the drive and plugging it directly into my laptop gives me sustained copy speeds of 120MB/s…

Is there anything I can change or tweak for better speeds over LAN? I’d like at least a minimum of 25-30MB/s (so USB 2.0 speeds).

Bump. This is seriously a limitation.

Could you see what copying the file over the LAN is like (ethernet, not wifi) … wifi is never going to get anywhere near full speeds.

Thanks for the reply. Just tried with Ethernet and the result is exactly the same. No idea why…

Also I benchmarked the drive with hdparm and these were my results:

root@DietPi:~# hdparm -Tt /dev/sda1

 Timing cached reads:   1650 MB in  2.00 seconds = 825.36 MB/sec
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 00 00 00 00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 Timing buffered disk reads: 352 MB in  3.02 seconds = 116.67 MB/sec

So I have no idea why I’m only able to get about 1/10th of that when copying files over via WiFi or Ethernet.

Any ideas someone? Could someone else please share their samba copy speeds?

Well I fixed it myself. The problem was using the exFAT filesystem for my external hard-drive. I reformatted it to ext4 and well, the results speak for themselves:

It’s great that your issue was resolved. I was about to suggest you migrate to NFS instead of SAMBA, since it’s usually quicker and it’s no problems setting it up even on Windows clients these days.