Rpi 3B+ - Network is unreachable right at first boot


I’ve used DietPi on 2 raspberrys in the past (a 4b and 3b+). And that’s the 1st time I have this issue and I really don’t understand.

I just flashed the microsd using win32diskimager, with dietpi armv8 iso. It shows initial volume resizing, then I am prompted to connect to root with login root and password dietpi, then I dismiss the informative message about dietpi initial config, and right after this I get this :

I don’t understand why it is trying to connect to a network, as I didn’t setup anything yet. There is no ethernet cable plugged, and I didn’t enter any wifi settings in dietpi-wifi.txt. I tried multiple times, I always have this error and it makes no sense. Do you think the pi has a material issue ?

Any answer is welcome, have a great day.

EDIT : I just tried with ARMv7 instead of ARMv8, exact same behaviour.

Probably a local network issue on your system. From the error menu, you have an option to open dietpi-config. Just check the network settings if you got an IP address assigned. Maybe you could set a Static IP fitting your network.

I tried to access dietpi-config, and I disabled the ethernet interface. Came back to initial setup, but the same issue happens again. But I don’t understand why it has issue with local network as it’s not connected to any network yet.

You need to enable Ethernet to get network/internet access. Or do you use wi-fi? Your system need internet access the complete installation. Without you are not able to continue. This is a must.

It also throws this error when an ethernet cable is plugged. This never happened to my Rpi4. I could flash the sd, plug it in the pi directly which is connected via ethernet, and connect through SSH. Here, I have this error too, and I can’t connect with SSH. I can confirm the ethernet it working. I don’t understand why it doesn’t connect right away.

Could be faulty Ethernet cable or something on local physical ports. Check inside network settings that you have an IP address assigned.