RPi 3B+ network disconnects while torrenting

Hello. I’m new here in this community and also to RPis. It’s my first one and what I wanted to do is a simple media center using Emby+CouchPotato+Sonarr to fetch movies and TV shows that I could later watch on my TV. But it seems that I am facing some problems here. When I try to download a movie using transmission my network connections always drop. I am connected via ethernet and have a 300mb/s fiber optic internet and when Transmission starts to download the speeds goes up to 20mb/s and then they suddenly drop, then goes up again and so on. When the speeds drop it seems that I also can’t use the SSH for about 30 seconds until the network connection “comes up” again. I tried downloading to a USB drive and external HDD with no luck - it always behaves the same. I also googled a little bit and found out that RPi ethernet connection uses USB ports so I thought that maybe that’s the case, but even when I disabled the ethernet adapter and tried everything connected only via WiFi it’s exactly the same. I even tried different torrent clients (qBitTorrent and Deluge) but I still have the same issue. This never happens when I download torrents using my MacBook so I guess it’s not a problem with my ISP either. Maybe some of you had these issues and know how to fix it? I would really appreciate that.

I am having the exact same issue on my 3B+ plus with dietpi 6.19.7. No matter what i try wifi or ethernet i still have the same problem. I also had this happen on my older 3B as well. I have a Zero-W which i am testing now but seems to happen more often when downloading multiple files in deluged at high speed.

Might not be able to handle all the ports open when torrenting…can be hundreds if not thousands of connections open, might set the TTL for connections to a shorter time so they timeout and close faster.


unsure of the keep alive time it needs to be…but default is usually set like 3600 which is WAY to long for torrenting