RPi 3A+ 5ghz Wifi not working


new to DietPi, trying v8.5 on a RPi 3A+ (the one without eth interface).
Initially tried the ARMv8 64-bit image, which didnt boot at all.

ARMv7 32-bit image does boot fine, so i continued to setup my wifi connection, but it does not work. I can do an SSID scan, it sees my 2.4 and 5 ghz ssids, i enter the password … after saving the credentials i can see a brief message it couldnt bring up eth0 (why does it try to bring up eth0 on the RPi 3A+ which does not have an ethernet interface?) and then conncts and starts DHCP discovery, never suceeds and then quits.

The entered credentials are 100% correct i checked several times. Are there known issues with the RPI3A+ and wifi? The only uncommon thing i did was to configure a 256mb memory split since i am going to do video related stuff on the device.

Any ideas anyone

Ok, i tried to enter the credentials for the 2.4ghz SSID, and it works … so: rephrasing the question :slight_smile: is there a known problem between DietPi / Rpi 3A+ and 5ghz Network Wifi Connections?

I am not aware of such issues. However is there enough signal to connect? The 5GHz band is more sensitive to obstacles.

That could be the problem, i dont know how well the RPi 3a+ wifi works in general given the fact it has no antennas… My laptops standing next to the RPI connect fine to the 5ghz network, but they do have internal antennas.

Wifi of RPis is generally pretty weak. :frowning: