RPi 3 w/SMB and transmission. Kodi cannot see all files.

first of all, thank you to all developer(s) of dietpi!

story: i had RP1 w/dietpi previously. was having problems and gave up (btw thank you for the help with troubleshooting fourdee). fast forward a few months later, decided to give it another go but this time with all of fourdee’s suggestion and RPi.

my current setup:
-stock RPi3
-official PSU
-samsung evo+ 16gb microsd
-insignia 8port powered usb hub
-seagate portable 500gb HDD
-dietpi w/SAMBA, proFTP, transmission, miniDLNA, LDXE+VNC

-clients: Amazon FTV stick and Win7 w/Kodi

Everything has been working amazing. But now i have a problem. All of the sudden my FTV sticks w/KODI can’t see some of the new files that Ive downloaded. Its 50% of the time. Sometimes I can see the new files added but not all the time. And the naming of the files are constant because i download weekly shows with same naming jus new episode numbers. With the Windows machine, i can see all files just fine. Do note that each folder has more than 60 files per folder. Could that be a limitation?

Any suggestions or help will be greatly appreciated. Again thank you to all the developers and FourDee!

Does sound like an issue with Amazon FTV stick, especially If the missing files are visible on the network with other machines.

Does the Amazon FTV stick (I dont own one) have a “refresh” feature similar to Kodi? This may force the stick to refresh and verify the media database.

Aside from that, if Amazon FTV stick supports FTP mounts and locations, you could try connecting to your media that way, instead of samba?

Out of sheer curiosity, I wonder what the output of lsof would be on the RPi? The only rationale there would be to see any file handles being held by one process (or another) that may explain IF there is anything on the PI side (smb/locks/etc) or if the stick side is an issue.

thanks for the reply guys!

so i was able to resolve the issue by restarting the AFTV stick. there is a “update library” function, but it only worked part of the time, but rebooting the hardware worked. It’s just tedious because the AFTV reboot process can take up to 4-5 minutes. lastly, i noticed the missing torrents i was downloading were partially due to torrent server error. for example when i downloaded episode 3, the server was giving me episode 2 to download, which i already had so it wouldn’t populate. :rofl:

anyway, after the reboot, it seems pretty solid now. if rebooting becomes routine, more than twice a week, ill end up doing the ftp mount. kodi has a vary of options for me to retrieve the file.

again thanks guys!

off topic: how would i mount and share another drive via samba?

You would need to manually add it into /etc/fstab.

Make a new folder for the mount:

mkdir -p /mnt/samba2

Edit fstab:

nano /etc/fstab

Under samba Client, duplicate the entry you have already. Then change the IP address, mount location, username and password eg:

// /mnt/samba2 cifs username=root,password=mypassword,_netdev,iocharset=utf8,sec=ntlm,nofail  0  0

Save and exit nano CTRL+O then CTRL+X.

Mount the new samba mount:

mount -a

You can check mount exists with:

df -h

thank you!