Retropie does not work on Bullseye

I all, I had Retropie installed via that worked well until I upgraded from Buster to Bullseye (the new Debian stable).
After the distro upgrade, I run the script to update all the Retropie packages. Some packets gets upgraded via new binary, other packages needs to be compiled from source. I encountered two issues now:

  • (Temporary solved) The installation of SDL1 fails due to

script. It is not yet able to handle “Debian 11” case so it fails. I’ve managed to temporary fix it by adding the case by myself. See

  • (Not solved) Emulationstation does not run anymore with error:
missing shared libraries: cannot open shared object file

This is because the emulationstation needed to be recompiled and some related packages was missing during the build.

If it helps, my sources.list are:

deb stable main contrib non-free
deb bullseye main

Has anyone had the same problem?

Yes on Bullseye Raspbian Dev have changed shared libraries quite a lot. Probably you would need to download the library manually. Similar to following topic

Thanks for the quick reply, I will try soon!
But does it mean the library is no more part of the distro and maintained? Retropie devs are still based on Debian 10, so I hope they will fix it officially when moving to 11…

well it’s related to Raspberry OS as they moved around libraries. Best to my knowledge Raspbian Foundation did not released Bullseye yet officially. Might be further changes need to be done on their side.

DietPi thenselves is not an own OS. We use Raspberry OS as base.

Just came back to say that today’s Raspberry OS is actually based on Bullsye since October, has per this changelog:

Also the “Stable” branch of Raspbian is “bullseye”:

Despite this, Retropie is still broken on latest Dietpi 7.9.