Restore Pi-Hole Address to /pihole

Hey so I just upgraded my pihole to 3.0 and during the installation, I got an error regarding the web UI. after a few minutes of google search, I found out that the solution was to do

git clone /var/www/html/admin

After doing the line above and repairing the installation, I can only access the pihole dashboard through IP.ADDRESS/admin now instead of IP.ADDRESS/pihole which I really liked.

How can I change it back to /pihole?



DietPi generates this symlink, we like it too :wink:

		# - Create a symlink so users can use http://ip/pihole
		ln -sf /var/www/html/admin /var/www/pihole

How did you update PiHole? pihole -up?

Sadly the command above didn’t work. I’m still getting a Website Blocked when I try to open /pihole
And yes, I did pihole -up to update it

Strange, does it say “Blocked by PiHole”?

Lets check status of /var/www

ls -lha /var/www
ls -lha /var/www/html

Yes it does

Well thats bizarre, PiHole is blocking our symlink lol.

I couldn’t replicate this on a fresh installation today. So it must be an issue with the blocked sites list, do you have any custom entries?

Yes, my adlist contains some of wally3k’s collection of domains All of which worked properly before the upgrade.

I went ahead and backed-up my current list and copied the default one from pi-hole’s github repo and ran

pihole -g

Sadly there’s no difference with the result

Tried to reinstall Pi-Hole. After the installation process, IP.ADDRESS/pihole just displays a blank page while IP.ADDRESS/admin shows the admin UI

Ok, sounds like the pihole symlink is missing, lets try and recreate it again:

rm -R /var/www/pihole
ln -sf /var/www/html/admin /var/www/pihole

Did you use DietPi-Software to uninstall, then install PiHole again?

Did the set of commands, still blank screen. And yes, I did use DietPi-Software to uninstall and reinstall

I think your lighttpd.conf has been overwritten during the PiHole update.

Assuming you are using the default Lighttpd webserver on DietPi:

Did you backup your lighttpd.conf before upgrading pihole, as per Updating PiHole::

If not, reinstall lighttpd to regenerate the config should fix this:

apt-get purge lighttpd -y
dietpi-software reinstall 84

Restoring the lighttpd.conf from a previous backup did the trick! Thank you!
Just wondering, I can still access the admin UI via the /admin address. Is that normal?


root@NanoPi-Neo:~# ls -lah /var/www/
insgesamt 88K
drwxrwxr-x  3 www-data www-data 4,0K Mai  6 16:07 .
drwxr-xr-x 13 root     root     4,0K Mai  6 15:57 ..
lrwxrwxrwx  1 www-data www-data   19 Mai  6 16:07 admin -> /var/www/html/admin
-rwxrwxr-x  1 www-data www-data  38K Mär 19 11:06 apc.php
drwxrwxr-x  4 www-data www-data 4,0K Mai  6 16:06 html
-rwxrwxr-x  1 www-data www-data   68 Mai  6 16:07 index.html
-rwxrwxr-x  1 www-data www-data 3,3K Mär  4 18:55 index.lighttpd.html
-rwxrwxr-x  1 www-data www-data  23K Mär 19 11:06 opcache.php
-rwxrwxr-x  1 www-data www-data   20 Mär 19 11:06 phpinfo.php
lrwxrwxrwx  1 www-data www-data   19 Mai  6 16:07 pihole -> /var/www/html/admin

If you don’t like this, remove the symbolic link:

lrwxrwxrwx  1 www-data www-data   19 Mai  6 16:07 admin -> /var/www/html/admin

Ah I see, haven’t really noticed it before. Thanks anyway!