RESOLVED: NUC 8i5BEH UEFI unable to install

Hi everyone,

Hope anyone can help with this:

-Have been using DietPi for a while on an older NUC (i3-6100u). Installed with UEFI x64 image without issues.

  • Last week i upgraded my NUC to an i5-8259u unit with the latest bios installed (077) On this configuration i cannot install the UEFI image, it simply does not recognize the USB stick as bootable / UEFI. I tried different USB drives to make sure.
    -A friend recently purchased the same NUC and also installed DietPi with the UEFI image without problems, but with a different bios version (much older 063). I then tried my USB drive on his NUC and this worked… Unfortunately i cannot downgrade the bios on my NUC
  • So it appears that the UEFI image works with some bios versions but not the latest?
  • Can i use the BIOS version of the x64 image to install to an SSD? It seems to install on the USB bootable device instead??

Am i missing something? Tip & tricks are most welcome because i wan’t to stay with DietPi…

Sincerely and the best wishes for 2020!


did you tried to install some other Debian Destro on your problematic NUC device? Just to check if everything is working fine. Once done you might be able to run DietPi Magic Script afterwards. This will transform the Debian Destro into DietPi.

Debian installs just fine, i think the problem is with the UEFI image / BIOS version combo… I will look into Magic Script

FInally installed aimage on USB drive, then placed disk in NUC and installed from here. Cumbersome but ir works… :slight_smile: