(resolved) Jessie - CurlFTPfs mount = emergency mode (dupe)

Duplicate issue, please use: http://dietpi.com/phpbb/viewtopic.php?f=9&t=142&start=10#p544

I installed DietPi, but after going through the install process. I lost SSH access, which makes troubleshooting a tad tricky. I can read the SD in my laptop.
ssh: connect to host port 22: Connection refused
During install, I changed to openSSH-server. Rummaging through the logs and filesystem, it appears it was installed and dropbear removed.
Any clues where I can look for clues as to what’s gone wrong? I went for ramlog 2, so have hourly logfiles.

Starting Nmap 6.47 ( http://nmap.org ) at 2015-10-21 01:49 BST
Nmap scan report for proxy.home (
Host is up (0.042s latency).
All 1000 scanned ports on proxy.home ( are closed

Nmap done: 1 IP address (1 host up) scanned in 0.63 seconds

It pings ok, arping gives the right MAC, it just doesn’t want to talk to me.

Hook it up to a monitor and see if it’s in emergency mode. Did you setup curlftpfs or samba?

I don’t have a monitor…
Yes to curlftps and samba install, but not setup yet

That could be the issue. Open /etc/fstab and append “nofail” to the options of all of the network drives. Let me know if that fixes the issue.

That fixed it! Samba was already nofail, curlftpfs wasn’t, but is now. Might be worth making that a default?

Yea, I pointed that out to Fourdee in my thread. Of course nofail is a good fallback, but the ftp drive isn’t mounting properly in the first place. I imagine he’ll have it fixed for the next update, now that he’s aware.

Yep, i left this out for curlftpfs. During Jessie testing, curlftps didn’t support the nofail attribute on the fstab entry. If i remember correctly, it would throw an error and prevent it being mounted.

I’ll run some tests today, also looks like the same issue Jig’s reporting: http://dietpi.com/phpbb/viewtopic.php?f=9&t=142&start=10#p530

Resolved for v98 release. Please see here: https://dietpi.com/forum/t/resolved-jessie-curlftpfs-mount-emergency-mode/127/14

I’ve locked this topic, please use the link above to continue discussions.