(resolved) eth0 disappears when launching DietPi utilities


I’m starting with DietPi (Wheezy) in my Raspberry Pi (model B). The dietpi-config program (or any other dietpi utility) can’t connect to Internet because, when I launch it, eth0 disappears from my interfaces list. When I go back to the command line, then only “lo” interface is up. The only way to make it work is by restarting the networks service (/etc/init.d/networking restart) from command line. But, of course, if I try to configure the system with DietPi utilities… back to the problem. Any help? Maybe it’s a common problem, but I didn’t find it in the forum.

Thank you in advance, and excuse my English… :thinking:


Have you already tried downloading a new image?
Please run dietpi-bugreport and post the reference code here. Make sure you have an active network connection.


I have the same problem with Wheezy and Jessie images (the versions available for downloading at this moment), and I can’t send a bug report because dietpi-bugreport takes down my eth0 interface (along with the Internet connection…). If I restart the networks service, everything is working and I have Internet connection (until I launch any dietpi utility).

I attach the generated offline bugreport (I changed the zip extension to rar). I’ll see if there is some mail or place more suitable for this report.

bugreport.rar (256 KB)

Thanks. Now we need to wait for Fourdee, because I don’t really have much experience in debugging :roll_eyes:

Hi Sysseon,

I’ve check through your system settings, everything is in order, except no network IP is in use. It does sound like a intermittent connection drop.

I’ll need some more info to assist you:

  • How are you writing the DietPi images to your SD card (eg: DD , win32diskimager)?
  • Are you using the network socket on your RPi, or a USB network adapter?
  • What network cable are you using?
  • What router/hub is the RPi connected to?
  • Whats your power supply for the RPi (eg: 5v 2amp)
  • I’ve noticed your using static IP. Have you tried changing to dhcp in either dietpi-config or /etc/network/interfaces?
  • Have you tried to manually bring up the eth0 (ifdown eth0, ifup eth0)?

What RPi model are your using (eg: B B+ Compute Module)?

Thank you, Fourdee. I was trying to answer your questions and I found the problem… I’m sorry for the inconvenience.

It seems that my USB hub (powered) doesn’t work very well. If the hub is connected, even with no devices connected to it, the network socket fails (I’m not using an USB adapter, my RPi is model B). If I unplug the hub, everything is working. My power supply is 5v 1amp. I’ll test with some other hub and power supply, since I’ve had a lot of problems with a lot of hubs in the RPi. I guess inexplicable things occurs when power supply is not enough…

Anyway, if you need some information, let me know. Thank you very much for your help!

Oh yea… I had this problem when I overclocked OpenElec and used only a 700 milliampère power supply.
Try to underclock it or use an other power supply.