(resolved) Don't delete Log files, please!

Hi,
I’m new (3 months) user of DietPi… I love it.

I’ve read https://dietpi.com/forum/t/dietpi-survey-information/32/1 tread

I have enabled the Full Log System (syslogd + logrotate).
I see the log files in /var/log in the disk (correct):

[…]
-rwxrwxr-x 1 root adm 153804 Nov 12 18:29 auth.log
-rwxrwxr-x 1 root adm 0 Nov 10 11:21 auth.log.1
-rwxrwxr-x 1 root adm 0 Nov 10 11:21 auth.log.2.gz
[…]

But when I reboot the DietPi deletes the using recent log and logrotate create example.log.1 0 Kb … I think this is not useful in Full Log System.
How can I change this option to not delete log files on reboot?

Thanks!

The only time DietPi will automatically delete log file contents is with the hourly cron job. This will only run if you have selected a DietPi-Ramlog mode 1/2. I’ll need to see some settings.

Whats the value of:

cat /DietPi/dietpi/.installed | grep 'INDEX_LOGGING_CURRENT ' | awk '{print $2}'

and

df -h
cat /DietPi/dietpi/.installed | grep 'INDEX_LOGGING_CURRENT ' | awk '{print $2}'

-3

df -h

/dev/root 59G 1.1G 58G 2% /
devtmpfs 483M 0 483M 0% /dev
tmpfs 487M 0 487M 0% /dev/shm
tmpfs 487M 6.5M 481M 2% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 487M 0 487M 0% /sys/fs/cgroup
tmpfs 10M 960K 9.1M 10% /DietPi
tmpfs 487M 0 487M 0% /tmp
/dev/mmcblk0p1 56M 21M 36M 37% /boot
tmpfs 98M 0 98M 0% /run/user/1000


Grazie!

Found the culprit, dietpi-ramlog is clearing log file contents during boot. This will be resolved in v101 update.

https://github.com/Fourdee/DietPi/issues/112