Resize partition on RPi4

I have Gparted installed in a Rasp. pi 4 with 4GB memory, but it does not work. See question and answers above.

Maybe a silly question, but how can I create a gparted live CD for the ARM architecture? The standard download from Gparted is for the x86 architecture.
Or do I miss something?

Many thanks in advance for the help and with kind regaards,
wimduk

If you want to increase it, you can try dietpi-drive_manager, and select the partition you wanna increase and follow the instructions. YOu can also use directly resize2fs tool.

If you want to decrease the size you would need to unmount the partition you wanna decrease. if it is the system partition you would need to mount it on another OS since you can not decrease an active system partition.

GParted does not support arm architecture at all:
NOTE: GParted Live is available in three different architectures

Architecture Description
amd64 64-bit version runs on x86-64 based computers, with ability to access more than 4 gigabytes of memory, and supports use of multiple processor cores. Works with UEFI secure boot.
i686 32-bit version runs on x86 and x86-64 based computers, limited to physical address space of 4 gigabytes, and uses one processor only.
i686-PAE 32-bit version runs on x86 (i686 and higher) and x86-64 based computers, with Physical Address Extension to access more than 4 gigabytes of memory, and supports use of multiple processor core

So you wanna shrink or enlarge what partition, the system partition or another one?

Best would be to start GParted Live on a desktop computer and connect the DietPi (SD/USB) device. This way you should be able to resize using GParted.

1 Like

Hi folks,
Thank you very much for your fast aand valuable replies. I am “born” with Gparted, since a very long time ago, on my other linux machines. And also my Raspberry supports it. Now I have to become familiar with the solutions you gave me. Many thanks again, wimduk

Does it throw an error or what do you mean by that?

Hi Jappe, that is a fast reply :sweat_smile:
No it does not give an error, but if I start Gparted the mousepoiter start to “turn” and after a minute or so the mousepointer comes back into the “normal” position (arrow)
:raising_hand_man: wimduk

hmm for me GParted is working without issues on RPi4. At least I can start the app

Thanks for the info Joulinar, I made a new install and try it again :raising_hand_man: wimduk

Hallo Joulinar and Jappe,
My problem is SOLVED (I think).
After a fresh installation I installed and started Gparted as root and everthing went fine. As user wim I have according to Dietpi not the right permissions to start Gparted and the loading process stops.
On my Raspberry I am allowed to start Gparted as user wim and then I am prompted to fill in the root password in a messagebox to continue. Small difference big surprise for a first time dietpi user :sweat_smile:
Many thanks for your great help :raising_hand_man:

I guess you would need sudo permission to start GParted. This would require creating a configuration for your vim user into /etc/sudoers.d

Where is the user wim coming from? Did you create it manually? When installing a desktop via dietpi-config, systemd-logind is installed alongside policykit, which provides a common interface for getting additional privileges from desktop/GUI sessions via credentials prompt. But not sure what GParted uses. Apart of this and sudo, there is also the disk system group, which grants raw disk access (pretty equivalent to root access from a security POV):

usermod -aG disk wim

For sudo access with password prompt (but the password of the user who calls sudo, not the root user):

echo 'wim ALL=(ALL:ALL) ALL' > /etc/sudoers.d/wim

Requires root permissions, obviously :wink:.

Created by OP I guess, because of his forum name

1 Like

Many thanks to you all for the help sofar, I will study it and will use it to my advantage :slight_smile: When my gparted problem occurs the installation was completed which means :

  1. unattended installation Dietpi via modified diepi.txt
  2. Additional programms and modifications installed with the script below.
    Thereafter I changed user root for wim en tried to load gparted.
#
#!/bin/bash
# Script-naam	: Inst_plus.sh
# Doel	        : Toevoegen en wijzigen Dietpi-software / Users.
# ---------------------------------------------------------------
# Toevoegen software
# ---------------------------------------------------------------
echo "Installatie ufw"
apt install -y ufw
echo "Installatie ysane"
apt install -y xsane
echo "Installatie Krusader"
apt install -y krusader
echo "Installatie libreoffice"
apt install -y libreoffice
# ---------------------------------------------------------------
# Toevoegen / wijzigen Users
# ---------------------------------------------------------------
echo "Gebruikers wim & johan toevoegen"
useradd -s /bin/bash -m -G adm,sudo wim
useradd -s /bin/bash -m -G adm,sudo johan
echo wim: xxxxx   | chpasswd
echo johan:xxxxx | chpasswd
echo "Password root wijzigen"
echo root: xxxxx   | chpasswd
# -----------------------------------------------------------------------

Regards wim :raising_hand_man: