REQ: Teamviewer

Hi everybody. First of all please excuse my bad English.
I installed this Teamviewer for armhf on my Raspberry Pi3 with Raspbian 8 and it works great. Then I tried to install it on my Orange Pi One with DietPi, but it failed to work.
Is there some big differences between Raspbian and DietPi that prevent Teamviewer to work? May be It is possible to look into this and make Teamviewer work?
The thing is that there is no alternative for Teamviewer, when you need remote control of any Pi board over Internet which is behind NAT, and you computer also behind NAT.


Yes, of course! Use OpenVPN Server and NoIP with VNC Server on your Orange Pi One, forward Port:UDP 1194 on your NAT Router to your Orange Pi One.
Open a VPN session on your Client computer and now you can connect to you Orange Pi One local address via VNC …

Teamviewer use his own server to manager your remote session … :open_mouth:

Of cause I use openvpn where it is possible. But imagine, that you have 10, 50 or even more Pi boards in different locations and you have no access to those places and routers there? If you setup a vpnserver in order they all (Pi boards) connect to it then how would you distinguish them? As for NoIP, I don’t know where are you from, but in my country when you use 3G/4G mobile connection you have no real IP you are behind provider’s NAT, so NoIP doesn’t work. I think that Teamviewer is much more convenient.


No, but simple, your device is unsupported.

System Requirements
Raspberry > Pi 2 > or Raspberry > Pi 3
(Raspberry Pi 1 and Zero currently > not supported> )

Raspbian 8.0 Jessie with X-Server or Framebuffer VT

35 MB disk space

May be I’m mistaking, but I think it’s possible, for example this thread (post #3)

And? Have you tried this?

I thought as much.

:~ # teamviewer setup

:~ # teamviewer status

Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
/opt/teamviewer/tv_bin/script/tvw_exec: line 40:  5122 Aborted              (core dumped) "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...

Has anyone managed to get teamviewer to work really need it

Tried this and it does not work

Could it be a dependencies issues?

sudo apt-get install libqt5gui5 libqt5qml5 libqt5quick5 libqt5webkit5 libqt5qml5 libqt5core5a qml-module-qtquick-controls qml-module-qtquick2 libqt5widgets5
sudo apt-get -f install
sudo dpkg -i teamviewer-host_armhf.deb

Hi thank you for the quick response I did try this everything installs and Teamviewer is there but it will not start…