Remote SSH access problem - SOLVED

Creating a bug report/issue

Required Information

  • DietPi version | v 8.9.2
  • Distro version | Bullseye
  • Kernel version | 5.10.0-18-amd64 #1 SMP Debian 5.10.140-1 (2022-09-02) x86_64 GNU/Linux
  • SBC model | Native PC (x86_64)
  • Power supply used | N/A
  • SD card used | N/A

Additional Information (if applicable)

  • Software title | OpenSSH
  • Was the software title installed freshly or updated/migrated? No
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Expected behaviour

Actual behaviour

Extra details

I have been running a Nextcloud server on an old laptop for a couple of years without issue. I have a NoIP domain name (secured with Letsencrypt) in order to access remotely. Via my local network, I can SSH in using KiTTy on my Windows laptop - I have set login via keys. The SSH server is running on port 3589. All working fine.

I have added etherwake to enable me to wake up other network devices. This works fine when connecting locally via SSH.

My problem is that if I try to connect remotely (I test using my phone and mobile data as a hotspot) using KiTTy on my Windows laptop, all I get is a timeout. I have set the Hostname in KiTTy to my domain name, and ensured the same port is specified. Port 3589 is forwarded in my router to the Nextcloud server. As I am using the same client, I have specified the same private key.

As my knowledge of Linux is somewhat limited, I hope someone could kindly offer a possible solution to enable me to gain remote access.

Thanks in advance.

UPDATE. Just thought I’d go through all the setup again. Guess what? Although I’d set up port forwarding on my router, there was a tickbox to enable the rule. It wasn’t enabled! Arrrghhhh! NOOB alert!!

Remote access working like a dream now.

Thx for sharing, even if the issue was sitting in front of the laptop. :rofl: