does not take a password

Hello all,

I have installed and now wanted to start the configuration via the connectd_installer. The email address could be entered, but the password cannot be entered. I also tried it with juiceSSH - same thing.
What am I doing wrong?

OS Linux Mint, Raspi3b+, Dietpi 7.12 latest version


basically connectd_installer is a tool provided by DietPi is just installing the tool. If there are challenges using this tool, it might be good to check with directly. Just to be sure, you used option 1 to login with username and password? Did you tried option 2 as well?

For testing purposes, I installed on my RPi3B+ 32bit and could enter username and password

********************* Sign In Menu *********************

     1) Sign in to your account with username and password
     2) Sign in to your account with access key and secret
     3) Exit

*  To create a account, please visit         *
*                                   *

Choose a menu selection (1 - 3):

Please enter your Username (e-mail address):

Please enter your password:

Hello Joulinar ,
Thank you for the quick reply.
I saw your screenshot and I have the option 2 only as an exit.
Is there another version on Dietpi ?
What am I doing wrong ?

after entering the enter key several times, this appears

API call to failed!
Reason for failure: Invalid authorization, Error code: INVALID_AUTH.
Contact with this information.

I’m a little bit confused. The screenshot you posted contains a password field. Did you try to enter something? The value you enter might be hidden, just type your password and continue.

What version of the connectd_installer you are running?

root@DietPi3:~# connectd_installer connection installer Version: 2.6.39 lib_v2.6.29
Modified: June 10, 2020 (library) April 24, 2021
Build date: Fri Apr 30 16:04:42 UTC 2021
curl with SSL support installed.

I’ve thought of that too and just entered the password like that and also copy and paste.
I briefly saw a few letters and numbers and then the curser got stuck.
My system has been running for 20 days and I installed your remotely via the software. connection installer Version: 2.5.38 lib_v2.1.26 
Modified: June 10, 2020 (library) November 10, 2020 
Build date: Thu Nov 12 18:13:26 UTC 2020
curl with SSL support installed.

Checking the daemon for compatibility... 

Using architecture arm-linaro-pi...

Checking your network for compatibility... 

Network connection OK...
Your network is compatible with services.

pls can you run dietpi-software reinstall 68 to get latest version of software

Hello Joulinar,

I have now uninstalled and reinstalled
After that I tried to log in “normally” with user and password.
Here, remote refused to enter the password as before.
Now with the 3rd function and the api key everything worked.

From experience, I assume - since it only works for me - that it is a system error during the Dietpi installation. I’ll probably re-install the whole thing soon and see if it’s still the same.

Many thanks for your quick help

as already said, this program is provided by There is nothing dietpi specific on it. We just install the software available. It there is something not working, like to enter the password, you might need to check with

Anyway it’s good that it is working now using api key

I have the solution to the problem from and it works !

The file in question is /usr/bin/connectd_library

If you wish to have the password displayed, edit this file (as root, or using sudo) and change line 1063 from

stty -echo


stty echo

thx for sharing. I guess entering the password should work without this change as well. It is just not shown. :slight_smile:

UPDATE: Remote.It has updated their installation process and have updated the daemon. Please refer to instructions here. Raspberry Pi

We are aware already DietPi-Software | Migrate away from deprecated installer by usk-tkhs · Pull Request #5790 · MichaIng/DietPi · GitHub